summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2023-10-22 00:08:12 (GMT)
committerGitHub <noreply@github.com>2023-10-22 00:08:12 (GMT)
commit4dfde6bac7395386379072c532560fbe8a5b6f79 (patch)
tree6e8e5aa1b9c72d5db6b1a1dd4fdbc6d97d4f4fc3 /test/Makefile.am
parent4b2d2eccdd8be50814ca2ed5e37e6d77b5a50340 (diff)
downloadhdf5-4dfde6bac7395386379072c532560fbe8a5b6f79.zip
hdf5-4dfde6bac7395386379072c532560fbe8a5b6f79.tar.gz
hdf5-4dfde6bac7395386379072c532560fbe8a5b6f79.tar.bz2
Fix file names in tfile.c (#3743)
Some tests in tfile.c use h5_fileaccess to get a VFD-dependent file name but use the scheme from testhdf5, reusing the FILE1 and FILE8 names. This leads to files like test1.h5.h5 which are unintended and not cleaned up. This changes the filename scheme for a few tests to work with h5test, resulting in more informative names and allowing the files to be cleaned up at the end of the test. The test files have also been added to the `make clean` target for the Autotools.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 3146e01..fdd83e5 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -229,7 +229,7 @@ CHECK_CLEANFILES+=accum.h5 cmpd_dset.h5 mdset.h5 compact_dataset.h5 dataset.h5 d
splitter*.h5 splitter.log mirror_rw mirror_ro event_set_[0-9].h5 \
cmpd_dtransform.h5 single_latest.h5 source_file.h5 stdio_file.h5 \
tfile_is_accessible.h5 tfile_is_accessible_non_hdf5.h5 tverbounds_dtype.h5 \
- virtual_file1.h5 flushrefresh_test
+ virtual_file1.h5 tfile_double_open.h5 tfile_incr_filesize.h5 flushrefresh_test
# Sources for testhdf5 executable
testhdf5_SOURCES=testhdf5.c tarray.c tattr.c tchecksum.c tconfig.c tfile.c \