summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2005-03-29 21:45:09 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2005-03-29 21:45:09 (GMT)
commita9d5fc42eb26da76fc7c3b5687552d4291bea1de (patch)
tree3856b4ecf6930bab7e9096bcc42980e8db95e82d /test/Makefile.am
parentd8b389836869c89801b9a1c2758d83b800b8f7b6 (diff)
downloadhdf5-a9d5fc42eb26da76fc7c3b5687552d4291bea1de.zip
hdf5-a9d5fc42eb26da76fc7c3b5687552d4291bea1de.tar.gz
hdf5-a9d5fc42eb26da76fc7c3b5687552d4291bea1de.tar.bz2
[svn-r10506] Purpose:
New feature Description: Add first iteration of "segmented heap" code, which will be used to store links in groups in a more flexible way than the previous "local heap" mechanism. Platforms tested: FreeBSD 4.11 (sleipnir) w/parallel Solaris 2.9 (shanti)
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 7935a39..2ba89e3 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -33,12 +33,13 @@ endif
# These are our main targets. They should be listed in the order to be
# executed, generally most specific tests to least specific tests.
-TEST_PROG=testhdf5 lheap ohdr stab gheap cache hyperslab istore bittests \
+TEST_PROG=testhdf5 lheap ohdr stab gheap cache btree2 blocktrack sheap \
+ hyperslab istore bittests \
dtypes dsets cmpd_dset extend external links unlink big mtime \
fillval mount flush1 flush2 enum \
- set_extent ttsafe stream_test \
+ set_extent ttsafe stream_test \
getname file_handle ntypes dangle dtransform filename reserved \
- btree2 blocktrack $(SRB_TESTS)
+ $(SRB_TESTS)
# List programs to be built when testing here. error_test and err_compat are
# built at the same time as the other tests, but executed by testerror.sh.
@@ -93,7 +94,7 @@ MOSTLYCLEANFILES=cmpd_dset.h5 compact_dataset.h5 dataset.h5 extend.h5 istore.h5\
family_file000[0-3][0-9].h5 multi_file-[rs].h5 core_file \
new_move_[ab].h5 ntypes.h5 dangle.h5 error_test.h5 err_compat.h5 \
dtransform.h5 test_filters.h5 get_file_name.h5 tstint[1-2].h5 \
- unlink_chunked.h5 btree2.h5 blocktrack.h5
+ unlink_chunked.h5 btree2.h5 blocktrack.h5 sheap.h5
# Sources for testhdf5 executable
testhdf5_SOURCES=testhdf5.c tarray.c tattr.c tconfig.c tfile.c tgenprop.c \