summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2020-02-03 17:59:14 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-05-20 14:31:54 (GMT)
commit06dfd6025d0798d53f74f40763a9d8effdf3c7de (patch)
tree1ef4300deea56fac750ce7634e9ef6cc7296fd2f /test/Makefile.am
parentecdaf09c11521dc87c38e840a4345284b547e7b1 (diff)
downloadhdf5-06dfd6025d0798d53f74f40763a9d8effdf3c7de.zip
hdf5-06dfd6025d0798d53f74f40763a9d8effdf3c7de.tar.gz
hdf5-06dfd6025d0798d53f74f40763a9d8effdf3c7de.tar.bz2
Replace pthread_self_ulong() with H5TS_thread_id(). The POSIX Threads
implementation ought to be portable to any system that has POSIX Threads. On Windows, I use the same API call as before.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index f9ede27..4e95641 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -72,7 +72,7 @@ TEST_PROG= testhdf5 \
flush1 flush2 app_ref enum set_extent ttsafe enc_dec_plist \
enc_dec_plist_cross_platform getname vfd ros3 s3comms hdfs ntypes \
dangle dtransform reserved cross_read freespace mf vds file_image \
- unregister cache_logging cork swmr vol
+ unregister cache_logging cork swmr thread_id vol
# List programs to be built when testing here.
# error_test and err_compat are built at the same time as the other tests, but executed by testerror.sh.