summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2020-03-20 20:20:51 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-03-20 20:20:51 (GMT)
commit51b8fa3ffefc17309ec45b36fa155486f9fbfec2 (patch)
treed8e14e5a32a40906c29cde6d13f05a6e4d936da7 /test/Makefile.am
parent52f8d8a1b1577d5053fa79662ab5eafd410a329e (diff)
downloadhdf5-51b8fa3ffefc17309ec45b36fa155486f9fbfec2.zip
hdf5-51b8fa3ffefc17309ec45b36fa155486f9fbfec2.tar.gz
hdf5-51b8fa3ffefc17309ec45b36fa155486f9fbfec2.tar.bz2
Take a stab at a "zoo" writer for VFD SWMR: write all of the same
objects as the cache_image test does. The zoo writer is a work in progress. This version is useful as a reproducer for the hang in the global heap that I stumbled over, yesterday. I run this to reproduce, env HLOG="pbio=on" ./vfd_swmr_zoo_writer -W -a
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 953816c..85350fb 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -47,7 +47,7 @@ SCRIPT_DEPEND = error_test$(EXEEXT) err_compat$(EXEEXT) links_env$(EXEEXT) \
vfd_swmr_remove_reader$(EXEEXT) vfd_swmr_remove_writer$(EXEEXT) \
vfd_swmr_addrem_writer$(EXEEXT) vfd_swmr_sparse_reader$(EXEEXT) \
vfd_swmr_sparse_writer$(EXEEXT) vfd_swmr_vlstr_writer$(EXEEXT) \
- vfd_swmr_vlstr_reader$(EXEEXT) \
+ vfd_swmr_vlstr_reader$(EXEEXT) vfd_swmr_zoo_writer$(EXEEXT) \
vds_env$(EXEEXT) \
vds_swmr_gen$(EXEEXT) vds_swmr_reader$(EXEEXT) vds_swmr_writer$(EXEEXT)
if HAVE_SHARED_CONDITIONAL
@@ -97,7 +97,7 @@ check_PROGRAMS=$(TEST_PROG) error_test err_compat tcheck_version \
vfd_swmr_generator vfd_swmr_reader vfd_swmr_writer \
vfd_swmr_remove_reader vfd_swmr_remove_writer vfd_swmr_addrem_writer \
vfd_swmr_sparse_reader vfd_swmr_sparse_writer \
- vfd_swmr_vlstr_reader vfd_swmr_vlstr_writer \
+ vfd_swmr_vlstr_reader vfd_swmr_vlstr_writer vfd_swmr_zoo_writer \
swmr_check_compat_vfd vds_env vds_swmr_gen vds_swmr_reader vds_swmr_writer
if HAVE_SHARED_CONDITIONAL
check_PROGRAMS+= filter_plugin vol_plugin
@@ -156,6 +156,9 @@ ttsafe_SOURCES=ttsafe.c ttsafe_dcreate.c ttsafe_error.c ttsafe_cancel.c \
ttsafe_acreate.c
cache_image_SOURCES=cache_image.c genall5.c
+
+vfd_swmr_zoo_writer_SOURCES=vfd_swmr_zoo_writer.c genall5.c
+
VFD_LIST = sec2 stdio core core_paged split multi family
if DIRECT_VFD_CONDITIONAL
VFD_LIST += direct