summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2019-11-13 17:49:15 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-05-20 14:19:37 (GMT)
commit6b80036fdecad893e2931daded31615e34d5e6f9 (patch)
tree4c7d685823374d1fce2a38d2bb8f27c9a3444f8b /test/Makefile.am
parentad2b1fa0c585206d3a819011bd2eabee6df3c8d3 (diff)
downloadhdf5-6b80036fdecad893e2931daded31615e34d5e6f9.zip
hdf5-6b80036fdecad893e2931daded31615e34d5e6f9.tar.gz
hdf5-6b80036fdecad893e2931daded31615e34d5e6f9.tar.bz2
Straggler from previous commit: build and link the new .c files where I
moved some previously-static variables and functions that were causing unused-variable/function warnings.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 68409fd..0702d4a 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -150,7 +150,7 @@ else
noinst_LTLIBRARIES=libh5test.la
endif
-libh5test_la_SOURCES=h5test.c testframe.c cache_common.c swmr_common.c external_common.c stubs.c vfd_swmr_common.c
+libh5test_la_SOURCES=h5test.c testframe.c cache_common.c swmr_common.c external_common.c vfd_swmr_common.c
# Use libhd5test.la to compile all of the tests
LDADD=libh5test.la $(LIBHDF5)
@@ -160,12 +160,17 @@ ttsafe_SOURCES=ttsafe.c ttsafe_dcreate.c ttsafe_error.c ttsafe_cancel.c \
ttsafe_acreate.c
cache_image_SOURCES=cache_image.c genall5.c
-
vfd_swmr_zoo_writer_SOURCES=vfd_swmr_zoo_writer.c genall5.c
vfd_swmr_zoo_reader_SOURCES=vfd_swmr_zoo_writer.c genall5.c
vfd_swmr_bigset_reader_SOURCES=vfd_swmr_bigset_writer.c
+#filter_plugin_SOURCES=filter_plugin.c
+
+vds_swmr_gen_SOURCES=vds_swmr_gen.c vds_swmr_common.c
+vds_swmr_writer_SOURCES=vds_swmr_writer.c vds_swmr_common.c
+vds_swmr_reader_SOURCES=vds_swmr_reader.c vds_swmr_common.c
+
VFD_LIST = sec2 stdio core core_paged split multi family
if DIRECT_VFD_CONDITIONAL
VFD_LIST += direct