summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2020-03-23 19:55:07 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-03-23 19:55:07 (GMT)
commitcb5e1ead29a66dcfdb7bee6e65ed76a9a93a3f9b (patch)
tree58514d4dc1954cb9deac08808ec686271f7e7413 /test/Makefile.am
parent51b8fa3ffefc17309ec45b36fa155486f9fbfec2 (diff)
downloadhdf5-cb5e1ead29a66dcfdb7bee6e65ed76a9a93a3f9b.zip
hdf5-cb5e1ead29a66dcfdb7bee6e65ed76a9a93a3f9b.tar.gz
hdf5-cb5e1ead29a66dcfdb7bee6e65ed76a9a93a3f9b.tar.bz2
Let tests provide a "hook" that runs after each step in create_zoo().
Provide a hook in vfd_swmr_zoo_writer that calls H5Fvfd_swmr_end_tick().
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 85350fb..58b2190 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -146,7 +146,7 @@ else
noinst_LTLIBRARIES=libh5test.la
endif
-libh5test_la_SOURCES=h5test.c testframe.c cache_common.c swmr_common.c external_common.c vfd_swmr_common.c
+libh5test_la_SOURCES=h5test.c testframe.c cache_common.c swmr_common.c external_common.c stubs.c vfd_swmr_common.c
# Use libhd5test.la to compile all of the tests
LDADD=libh5test.la $(LIBHDF5)