summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2013-06-12 16:29:09 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2013-06-12 16:29:09 (GMT)
commitd01b40e43956e8494b7b536c8cca6246b81fe887 (patch)
treed78335668556f63ae231b51a023e513b7cbb5dd1 /test/Makefile.am
parenta33955d60f3d6bd85f32b3b21f4f6ffb63ea1121 (diff)
downloadhdf5-d01b40e43956e8494b7b536c8cca6246b81fe887.zip
hdf5-d01b40e43956e8494b7b536c8cca6246b81fe887.tar.gz
hdf5-d01b40e43956e8494b7b536c8cca6246b81fe887.tar.bz2
[svn-r23760] Implement SWMR-5:
Implemented use case 1.8 program--SWRM read/write multiple chunks at a time. test/use_append_mchunks.c: The program. test/Makefile.am: test/Makefile.in: Added program use_append_mchunks. test/test_usecases.sh.in: Added simple tests for use_append_mchunks. MANIFEST: Updated for new file. Tested: h5committest, except cmake, passed. Hand tested in Koala for various options.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 03241c1..397d20f 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -51,7 +51,7 @@ TEST_PROG= testhdf5 lheap ohdr stab gheap cache cache_api cache_tagging \
bin_PROGRAMS=swmr_generator swmr_reader swmr_writer swmr_remove_reader \
swmr_remove_writer swmr_addrem_writer swmr_sparse_reader swmr_sparse_writer \
- use_append_chunk
+ use_append_chunk use_append_mchunks
# List programs to be built when testing here. error_test and err_compat are
# built at the same time as the other tests, but executed by testerror.sh.
@@ -159,7 +159,7 @@ CHECK_CLEANFILES+=accum.h5 cmpd_dset.h5 compact_dataset.h5 dataset.h5 \
new_multi_file_v16-r.h5 new_multi_file_v16-s.h5 \
split_get_file_image_test-m.h5 split_get_file_image_test-r.h5 \
file_image_core_test.h5.copy \
- swmr_data.h5 use_append_chunk.h5 \
+ swmr_data.h5 use_append_chunk.h5 use_append_mchunks.h5 \
flushrefresh.h5 flushrefresh_VERIFICATION_START \
flushrefresh_VERIFICATION_CHECKPOINT1 flushrefresh_VERIFICATION_CHECKPOINT2 \
flushrefresh_VERIFICATION_DONE
@@ -172,6 +172,7 @@ testhdf5_SOURCES=testhdf5.c tarray.c tattr.c tchecksum.c tconfig.c tfile.c \
# Sources for Use Cases
use_append_chunk_SOURCES=use_append_chunk.c use_common.c
+use_append_mchunks_SOURCES=use_append_mchunks.c use_common.c
# Temporary files.
DISTCLEANFILES=testerror.sh testlibinfo.sh testcheck_version.sh testlinks_env.sh test_plugin.sh \