summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2005-06-17 13:33:36 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2005-06-17 13:33:36 (GMT)
commit0d6e379701f8773b458e511b6444e43430170c5e (patch)
tree9ae291e61617a9369270046cc26f5bcc9a2bbbb8 /test/Makefile.am
parentd37e4e148819531404a68cd395dbef0d12cfee8a (diff)
downloadhdf5-0d6e379701f8773b458e511b6444e43430170c5e.zip
hdf5-0d6e379701f8773b458e511b6444e43430170c5e.tar.gz
hdf5-0d6e379701f8773b458e511b6444e43430170c5e.tar.bz2
[svn-r10931] Purpose: Adjust Test Program and Rename
Description: Renamed test/dt_atomic.c to test/dt_arith.c(an abbreviation of "arithmetic data types") to better describe the program. This checkin broke down into three sections when the floating-point numbers are the source, normalized, denormalized, and special values. If there's any difference of destination values, only normalized value test reports failure. The other 2 report only as warning. Platforms tested: h5commitest and fuss Misc. update: MANIFEST
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index b3f888a..1243639 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -30,7 +30,7 @@ check_SCRIPTS = $(TEST_SCRIPT)
# These are our main targets. They should be listed in the order to be
# executed, generally most specific tests to least specific tests.
TEST_PROG=testhdf5 lheap ohdr stab gheap cache btree2 blocktrack sheap \
- pool hyperslab istore bittests dt_atomic \
+ pool hyperslab istore bittests dt_arith \
dtypes dsets cmpd_dset extend external links unlink big mtime \
fillval mount flush1 flush2 enum \
set_extent ttsafe stream_test \
@@ -78,9 +78,9 @@ timings _timings: testmeta
# the temporary file name in ways that the makefile is not aware of.
MOSTLYCLEANFILES=cmpd_dset.h5 compact_dataset.h5 dataset.h5 extend.h5 istore.h5\
tfile[1-4].h5 th5s[1-3].h5 lheap.h5 ohdr.h5 stab[1-2].h5 \
- extern_[1-3].h5 extern_[1-4][ab].raw gheap[0-4].h5 dt_atomic[1-2]\
+ extern_[1-3].h5 extern_[1-4][ab].raw gheap[0-4].h5 dt_arith[1-2]\
links.h5 links[1-3].h5 big.data big[0-9][0-9][0-9][0-9][0-9].h5 \
- dtypes[1-8].h5 dt_atomic[1-2].h5 tattr.h5 tselect.h5 mtime.h5 \
+ dtypes[1-8].h5 dt_arith[1-2].h5 tattr.h5 tselect.h5 mtime.h5 \
unlink.h5 unicode.h5 \
fillval_[0-9].h5 fillval.raw mount_[0-9].h5 testmeta.h5 ttime.h5 \
trefer[1-3].h5 tvltypes.h5 tvlstr.h5 tvlstr2.h5 flush.h5 \