summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2009-09-18 18:34:37 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2009-09-18 18:34:37 (GMT)
commit3a83be48fb88572d675507a5d5cfbacb302f1ad7 (patch)
tree62a02358948629bd268d90e0e1ac79496276cf07 /test/Makefile.am
parent8664cb26c3da2749e4c82d99454701352cc15b0e (diff)
downloadhdf5-3a83be48fb88572d675507a5d5cfbacb302f1ad7.zip
hdf5-3a83be48fb88572d675507a5d5cfbacb302f1ad7.tar.gz
hdf5-3a83be48fb88572d675507a5d5cfbacb302f1ad7.tar.bz2
[svn-r17499] Purpose:
Stage 2 implementation of embedded library information feature. H5.c: added code to print the embedded library information when there is a library versions mis-match occurs. This ensures the library information string is included in the executable. Also modifies the code so that the Library mismatch warning string is included only once in the executable. H5private.h: Added a global reference to the libinfo string variable to prepare for possible stage 3 implementation of a public API. test/testlibinfo.sh.in: A new test added to verify the library information is indeed included in the executables. configure.in: configure: Added entry to auto-generate test/testlibinfo.sh. H5detect.c: Modified the libhdf5settings generating code to allow it to insert the strings to a file other than stdout. This maybe needed in stage 3 implementation. MANIFEST: updated with the newly added file of testlibinfo.sh.in. Tested: h5committest passed. Also passed jam in serial mode.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 958d4c5..f0aa131 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -24,7 +24,7 @@ include $(top_srcdir)/config/commence.am
INCLUDES=-I$(top_srcdir)/src -I$(top_builddir)/src
# Test script for error_test and err_compat
-TEST_SCRIPT = testerror.sh
+TEST_SCRIPT = testerror.sh testlibinfo.sh
check_SCRIPTS = $(TEST_SCRIPT)
SCRIPT_DEPEND = error_test$(EXEEXT) err_compat$(EXEEXT)