summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2011-06-23 16:40:31 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2011-06-23 16:40:31 (GMT)
commit6e55bfba8a8c203aa0b06638de3655cf823b954e (patch)
treea008dc7c5b7939576713d4ef779c1b86f7053fa4 /test/Makefile.am
parentb5fbe95269323490a89f6d580a215c4763c18a2a (diff)
downloadhdf5-6e55bfba8a8c203aa0b06638de3655cf823b954e.zip
hdf5-6e55bfba8a8c203aa0b06638de3655cf823b954e.tar.gz
hdf5-6e55bfba8a8c203aa0b06638de3655cf823b954e.tar.bz2
[svn-r21024] Bug fix for Issue 2598 - In v1.6 library, there was EOA for the whole MULTI file saved in the
super block. We took it out in v1.8 library because it's meaningless for the MULTI file. v1.8 library saves the EOA for the metadata file, instead. But this caused some backward compatibility problem. v1.8 library couldn't open the file created with v1.6 library. I fixed the problem by checking the EOA value to detect the file created with v1.6 library. Tested on jam, koala, and linew.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 65bf872..52283bd 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -124,7 +124,8 @@ CHECK_CLEANFILES+=accum.h5 cmpd_dset.h5 compact_dataset.h5 dataset.h5 dset_offse
dtransform.h5 test_filters.h5 get_file_name.h5 tstint[1-2].h5 \
unlink_chunked.h5 btree2.h5 objcopy_src.h5 objcopy_dst.h5 \
objcopy_ext.dat trefer1.h5 trefer2.h5 app_ref.h5 tcheck_version_*.out \
- tcheck_version_*.err efc[0-5].h5 log_vfd_out.log
+ tcheck_version_*.err efc[0-5].h5 log_vfd_out.log \
+ new_multi_file_v16-r.h5 new_multi_file_v16-s.h5
# Sources for testhdf5 executable
testhdf5_SOURCES=testhdf5.c tarray.c tattr.c tchecksum.c tconfig.c tfile.c \