summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2013-05-14 19:56:51 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2013-05-14 19:56:51 (GMT)
commit71af5b7480cb0f0aa689640972f8e96fef1e60f0 (patch)
treeab8e74253d276931a20d40a0df8a2de6692026fe /test/Makefile.am
parent811ac68ac24972a1392fc9f6d20ae96286b2db7a (diff)
downloadhdf5-71af5b7480cb0f0aa689640972f8e96fef1e60f0.zip
hdf5-71af5b7480cb0f0aa689640972f8e96fef1e60f0.tar.gz
hdf5-71af5b7480cb0f0aa689640972f8e96fef1e60f0.tar.bz2
[svn-r23702] Issue 8380 - H5Zunregister caused seg fault. This is a porting of code from the trunk. It fixes the problem by first iterating
through all opened datasets and groups to see if any of them uses the filter. If it finds one, the function fails with a message. Then the function flushes all opened files. Tested with h5committest.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 15a2668..6b23566 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -46,7 +46,7 @@ TEST_PROG=testhdf5 lheap ohdr stab gheap cache cache_api \
big mtime fillval mount flush1 flush2 app_ref enum \
set_extent ttsafe \
getname vfd ntypes dangle dtransform reserved cross_read \
- freespace mf btree2 fheap file_image
+ freespace mf btree2 fheap file_image unregister
# List programs to be built when testing here. error_test and err_compat are
# built at the same time as the other tests, but executed by testerror.sh.
@@ -150,7 +150,7 @@ CHECK_CLEANFILES+=accum.h5 cmpd_dset.h5 compact_dataset.h5 dataset.h5 dset_offse
tcheck_version_*.err efc[0-5].h5 log_vfd_out.log \
new_multi_file_v16-r.h5 new_multi_file_v16-s.h5 \
split_get_file_image_test-m.h5 split_get_file_image_test-r.h5 \
- file_image_core_test.h5.copy
+ file_image_core_test.h5.copy unregister_filter_1.h5 unregister_filter_2.h5
# Sources for testhdf5 executable
testhdf5_SOURCES=testhdf5.c tarray.c tattr.c tchecksum.c tconfig.c tfile.c \