summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2020-02-03 17:59:14 (GMT)
committerQuincey Koziol <koziol@koziol.gov>2020-05-06 20:37:14 (GMT)
commit763d7a778e7b08a0f6bffcd6c471dbcd02147141 (patch)
treea772aef0ea894056bb4e0210f3a28588011edcb5 /test/Makefile.am
parent25f30e7d63ac3c567b38233a2d4b6d3472754754 (diff)
downloadhdf5-763d7a778e7b08a0f6bffcd6c471dbcd02147141.zip
hdf5-763d7a778e7b08a0f6bffcd6c471dbcd02147141.tar.gz
hdf5-763d7a778e7b08a0f6bffcd6c471dbcd02147141.tar.bz2
Replace pthread_self_ulong() with H5TS_thread_id(). The POSIX Threads
implementation ought to be portable to any system that has POSIX Threads. On Windows, I use the same API call as before.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index f62d2fd..a60d0a8 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -63,7 +63,7 @@ TEST_PROG= testhdf5 \
flush1 flush2 app_ref enum set_extent ttsafe enc_dec_plist \
enc_dec_plist_cross_platform getname vfd ros3 s3comms hdfs ntypes \
dangle dtransform reserved cross_read freespace mf vds file_image \
- unregister cache_logging cork swmr vol
+ unregister cache_logging cork swmr thread_id vol
# List programs to be built when testing here.
# error_test and err_compat are built at the same time as the other tests, but executed by testerror.sh.