summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-03-29 17:38:17 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-03-29 17:38:17 (GMT)
commit7acf3f1b12cb743850f2ae4a13d67a080fc26793 (patch)
tree76ff86178b02b6329483b0975862032e73d1a991 /test/Makefile.am
parent9e4b79ad482c7fe41e893dac8f52b101fcdc38c3 (diff)
downloadhdf5-7acf3f1b12cb743850f2ae4a13d67a080fc26793.zip
hdf5-7acf3f1b12cb743850f2ae4a13d67a080fc26793.tar.gz
hdf5-7acf3f1b12cb743850f2ae4a13d67a080fc26793.tar.bz2
[svn-r10475] Purpose:
Feature - conditional compilation Description: SRB file driver and tests are now compiled only when SRB is enabled (using --with-srb during configure). Solution: Added an automake conditional in configure.in, altered Makefiles.am in src and test directories to depend on that conditional. This should make a nice example for posterity to add conditionally compiled sources. Platforms tested: heping (only configure change)
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index a7db7d9..7935a39 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -26,14 +26,19 @@ INCLUDES=-I$(top_srcdir)/src -I$(top_builddir)/src
TEST_SCRIPT = $(top_srcdir)/test/testerror.sh
check_SCRIPTS = $(TEST_SCRIPT)
+# Build and run SRB tests only if SRB driver is enabled.
+if BUILD_SRB_CONDITIONAL
+ SRB_TESTS=srb_write srb_append srb_read
+endif
+
# These are our main targets. They should be listed in the order to be
# executed, generally most specific tests to least specific tests.
TEST_PROG=testhdf5 lheap ohdr stab gheap cache hyperslab istore bittests \
dtypes dsets cmpd_dset extend external links unlink big mtime \
fillval mount flush1 flush2 enum \
- set_extent srb_write srb_append srb_read ttsafe stream_test \
+ set_extent ttsafe stream_test \
getname file_handle ntypes dangle dtransform filename reserved \
- btree2 blocktrack
+ btree2 blocktrack $(SRB_TESTS)
# List programs to be built when testing here. error_test and err_compat are
# built at the same time as the other tests, but executed by testerror.sh.