summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2020-02-03 17:59:14 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-02-03 17:59:14 (GMT)
commit986c7451a03aa8d54ce3b57ffd2e394665d360cc (patch)
treef026b4f18a17976c4f2072f5082bfa2654547b06 /test/Makefile.am
parent0147d2493eed235ba31077a6da38608ce2fe152a (diff)
downloadhdf5-986c7451a03aa8d54ce3b57ffd2e394665d360cc.zip
hdf5-986c7451a03aa8d54ce3b57ffd2e394665d360cc.tar.gz
hdf5-986c7451a03aa8d54ce3b57ffd2e394665d360cc.tar.bz2
Replace pthread_self_ulong() with H5TS_thread_id(). The POSIX Threads
implementation ought to be portable to any system that has POSIX Threads. On Windows, I use the same API call as before.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 57080aa..dd0a579 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -63,7 +63,7 @@ TEST_PROG= testhdf5 \
flush1 flush2 app_ref enum set_extent ttsafe enc_dec_plist \
enc_dec_plist_cross_platform getname vfd ros3 s3comms hdfs ntypes \
dangle dtransform reserved cross_read freespace mf vds file_image \
- unregister cache_logging cork swmr vol
+ unregister cache_logging cork swmr thread_id vol
# List programs to be built when testing here.
# error_test and err_compat are built at the same time as the other tests, but executed by testerror.sh.