summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2020-02-05 19:34:00 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-02-05 19:34:00 (GMT)
commit00608a8756330fc387cde90c397562103c857671 (patch)
tree53b8017bdaf1c30e8926d4f923771a72f6c0372f /test/Makefile.am
parent7ab0fa2d7c3b23e1e6dfd9f33833f5ac536ee9fb (diff)
parentcefacee21b5ad569e2394b32793648e1b80f3d6b (diff)
downloadhdf5-00608a8756330fc387cde90c397562103c857671.zip
hdf5-00608a8756330fc387cde90c397562103c857671.tar.gz
hdf5-00608a8756330fc387cde90c397562103c857671.tar.bz2
Merge pull request #2341 in HDFFV/hdf5 from ~DYOUNG/werror:thread_id to develop
* commit 'cefacee21b5ad569e2394b32793648e1b80f3d6b': src/H5Eint.c: #include H5TSprivate.h for H5TS_thread_id() definitions. Change thread IDs to uint64_t from unsigned long, per Quincey's suggestion. Add thread_id.c to the MANIFEST and the CMakeLists.txt per Allen's request. Replace pthread_self_ulong() with H5TS_thread_id(). The POSIX Threads implementation ought to be portable to any system that has POSIX Threads. On Windows, I use the same API call as before.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 57080aa..dd0a579 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -63,7 +63,7 @@ TEST_PROG= testhdf5 \
flush1 flush2 app_ref enum set_extent ttsafe enc_dec_plist \
enc_dec_plist_cross_platform getname vfd ros3 s3comms hdfs ntypes \
dangle dtransform reserved cross_read freespace mf vds file_image \
- unregister cache_logging cork swmr vol
+ unregister cache_logging cork swmr thread_id vol
# List programs to be built when testing here.
# error_test and err_compat are built at the same time as the other tests, but executed by testerror.sh.