summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2013-03-28 20:14:11 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2013-03-28 20:14:11 (GMT)
commit3374ffecf828a4e7a4e7566c3bd7315121c656d1 (patch)
treee5cadf2fc1446a16db6f7c21920648242ebe3385 /test/Makefile.am
parent9138b343aa6b3e314ef6e0a332a2ba3570311427 (diff)
downloadhdf5-3374ffecf828a4e7a4e7566c3bd7315121c656d1.zip
hdf5-3374ffecf828a4e7a4e7566c3bd7315121c656d1.tar.gz
hdf5-3374ffecf828a4e7a4e7566c3bd7315121c656d1.tar.bz2
[svn-r23482] I changed the plugin library to be built as shared library only when configure enables shared. libtool will install the shared plugin library. I put a remove command in test/Makefile.am to delete the unnecessary plugin library.
Tested on jam, koala, and emu.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 62b309d..61f1ed5 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -78,12 +78,16 @@ endif
if HAVE_SHARED_CONDITIONAL
# The libh5test library provides common support code for the tests.
- noinst_LTLIBRARIES=libh5test.la libdynlib1.la
+ noinst_LTLIBRARIES=libh5test.la
# The libdynlib1 library for testing plugin module plugin.c.
# Build it as shared library if configure is enabled for shared library.
+ lib_LTLIBRARIES=libdynlib1.la
libdynlib1_la_SOURCES=dynlib1.c
- libdynlib1_la_LDFLAGS=-rpath /tmp
+
+install-data-local:
+ $(RM) $(DESTDIR)$(libdir)/*dynlib1*
+
else
# The libh5test library provides common support code for the tests.
noinst_LTLIBRARIES=libh5test.la