summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-03-28 17:17:19 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-03-28 17:17:19 (GMT)
commit9138b343aa6b3e314ef6e0a332a2ba3570311427 (patch)
treeeda15db2e838cd7a1226b4c36597edd2092582c9 /test/Makefile.am
parentc76847d107d5fab28e6b9ced5b054669064e984a (diff)
downloadhdf5-9138b343aa6b3e314ef6e0a332a2ba3570311427.zip
hdf5-9138b343aa6b3e314ef6e0a332a2ba3570311427.tar.gz
hdf5-9138b343aa6b3e314ef6e0a332a2ba3570311427.tar.bz2
[svn-r23480] Reposition conditional and libtool commands.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index df6a9e5..62b309d 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -24,12 +24,11 @@ include $(top_srcdir)/config/commence.am
INCLUDES=-I$(top_srcdir)/src -I$(top_builddir)/src
# Test script for error_test and err_compat
+TEST_SCRIPT = testerror.sh testlibinfo.sh testcheck_version.sh testlinks_env.sh
+SCRIPT_DEPEND = error_test$(EXEEXT) err_compat$(EXEEXT) links_env$(EXEEXT)
if HAVE_SHARED_CONDITIONAL
- TEST_SCRIPT = testerror.sh testlibinfo.sh testcheck_version.sh testlinks_env.sh test_plugin.sh
- SCRIPT_DEPEND = error_test$(EXEEXT) err_compat$(EXEEXT) links_env$(EXEEXT) plugin$(EXEEXT)
-else
- TEST_SCRIPT = testerror.sh testlibinfo.sh testcheck_version.sh testlinks_env.sh
- SCRIPT_DEPEND = error_test$(EXEEXT) err_compat$(EXEEXT) links_env$(EXEEXT)
+ TEST_SCRIPT += test_plugin.sh
+ SCRIPT_DEPEND += plugin$(EXEEXT)
endif
check_SCRIPTS = $(TEST_SCRIPT)
@@ -55,10 +54,10 @@ TEST_PROG= testhdf5 lheap ohdr stab gheap cache cache_api cache_tagging \
# 'make check' doesn't run them directly, so they are not included in TEST_PROG.
# Also build testmeta, which is used for timings test. It builds quickly,
# and this lets automake keep all its test programs in one place.
+check_PROGRAMS=$(TEST_PROG) error_test err_compat tcheck_version testmeta links_env
if HAVE_SHARED_CONDITIONAL
- check_PROGRAMS=$(TEST_PROG) error_test err_compat tcheck_version testmeta links_env plugin
+ check_PROGRAMS+= plugin
else
- check_PROGRAMS=$(TEST_PROG) error_test err_compat tcheck_version testmeta links_env
endif
# These programs generate test files for the tests. They don't need to be
@@ -99,10 +98,9 @@ LDADD=libh5test.la $(LIBHDF5)
ttsafe_SOURCES=ttsafe.c ttsafe_dcreate.c ttsafe_error.c ttsafe_cancel.c \
ttsafe_acreate.c
+VFD_LIST = sec2 stdio core split multi family
if DIRECT_VFD_CONDITIONAL
- VFD_LIST = sec2 stdio core split multi family direct
-else
- VFD_LIST = sec2 stdio core split multi family
+ VFD_LIST += direct
endif
# Additional target for running timing test