summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorNeil Fortner <nfortne2@hdfgroup.org>2010-07-16 16:32:49 (GMT)
committerNeil Fortner <nfortne2@hdfgroup.org>2010-07-16 16:32:49 (GMT)
commitc22b8a94f2b6920e03f8390415269f9333eeb077 (patch)
tree44da189a5048fd7a9de087049e4f80119e0451ab /test/Makefile.am
parent0dce71a0a30314da545f1f90a26f537c467b043a (diff)
downloadhdf5-c22b8a94f2b6920e03f8390415269f9333eeb077.zip
hdf5-c22b8a94f2b6920e03f8390415269f9333eeb077.tar.gz
hdf5-c22b8a94f2b6920e03f8390415269f9333eeb077.tar.bz2
[svn-r19076] Purpose: Fix bug 1951
Description: A bug introduced in 1.8.5 causes local heap data blocks to be mis-aligned when sizeof_offsets + 2*sizeof_lengths is not a multiple of 8. In this case, the address of the data block as stored in the heap prefix is aligned but the actual data block is not. This causes files created with these sizes to be corrupted, and prevents uncorrupted files with these sizes to be unreadable. Modified local heap code to account for alignment. Tested: jam, amani, linew (h5committest)
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 043e05d..07df450 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -62,7 +62,8 @@ check_PROGRAMS=$(TEST_PROG) error_test err_compat tcheck_version testmeta
# so do not appear in this list.
BUILD_ALL_PROGS=gen_bad_ohdr gen_bogus gen_cross gen_deflate gen_filters gen_new_array \
gen_new_fill gen_new_group gen_new_mtime gen_new_super gen_noencoder \
- gen_nullspace gen_udlinks space_overflow gen_filespace gen_specmetaread
+ gen_nullspace gen_udlinks space_overflow gen_filespace gen_specmetaread \
+ gen_sizes_lheap
if BUILD_ALL_CONDITIONAL
noinst_PROGRAMS=$(BUILD_ALL_PROGS)