summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2013-03-29 20:59:15 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2013-03-29 20:59:15 (GMT)
commited621aae38837e90c7273087de22f1752eee7cc7 (patch)
tree9d4ccc718d360469fd99c793cd9526c8981efb9b /test/Makefile.am
parent5e5e9e3987ddb5ce005f346e95e378e57ad5c762 (diff)
downloadhdf5-ed621aae38837e90c7273087de22f1752eee7cc7.zip
hdf5-ed621aae38837e90c7273087de22f1752eee7cc7.tar.gz
hdf5-ed621aae38837e90c7273087de22f1752eee7cc7.tar.bz2
[svn-r23494] I added another filter library dynlib2.c for plugin.c test. The test script moves the libdynlib2.so to /tmp then runs
plugin.c. Tested on jam and koala.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 6e1f845..ec0f416 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -79,13 +79,14 @@ if HAVE_SHARED_CONDITIONAL
# The libh5test library provides common support code for the tests.
noinst_LTLIBRARIES=libh5test.la
- # The libdynlib1 library for testing plugin module plugin.c.
+ # The libdynlib1 and libdynlib2 library for testing plugin module plugin.c.
# Build it as shared library if configure is enabled for shared library.
- lib_LTLIBRARIES=libdynlib1.la
+ lib_LTLIBRARIES=libdynlib1.la libdynlib2.la
libdynlib1_la_SOURCES=dynlib1.c
+ libdynlib2_la_SOURCES=dynlib2.c
install-data-local:
- $(RM) $(DESTDIR)$(libdir)/*dynlib1*
+ $(RM) $(DESTDIR)$(libdir)/*dynlib*
else
# The libh5test library provides common support code for the tests.