summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorjake.smith <jake.smith@hdfgroup.org>2018-12-29 20:31:31 (GMT)
committerjake.smith <jake.smith@hdfgroup.org>2018-12-29 20:31:31 (GMT)
commit905c3ca3d7736b151ff0889290c0c9e377988f26 (patch)
tree3b6d8b5ab846dcf0a29bf14460e5058096e78800 /test/Makefile.am
parentba095e6a53a919c9753463c3800a26b180b7a135 (diff)
parentf54fb420d08ea0a7e7b026150c0ab559803e0acd (diff)
downloadhdf5-905c3ca3d7736b151ff0889290c0c9e377988f26.zip
hdf5-905c3ca3d7736b151ff0889290c0c9e377988f26.tar.gz
hdf5-905c3ca3d7736b151ff0889290c0c9e377988f26.tar.bz2
Merge pull request #1372 in HDFFV/hdf5 from ~JAKE.SMITH/hdf5:dset_ohdr_minimize to develop
Dataset object header minimization Jira TRILAB-45 * commit 'f54fb420d08ea0a7e7b026150c0ab559803e0acd': (34 commits) Specify variable type. Remove unnecessary whitespace. OHDR tests now accept h5_fileaccess() fapls. Formatting, informative comments, and minor renaming. Fix some CMake listings Add error checking to the minimized dset header size calculation. Update printf->HDprintf statements. Remove `#if 0` block of deprecated code. Fix mistake with H5E_BEGIN_TRY {...} H5E_END_TRY block containing ERROR-raising macros. Formatting tweaks. Add "compact" storage test to relative header size comparisons. Formatting adjustments. Formatting adjustments Move H5Fset_dset_no_attrs_hint VOL operations to native. Move minimzied object header tests from separate file to test/ohdr.c Some formatting changes. Re-format test/ohdr_mindset.c Fix a few transcription errors in other test files. formatting adjustments Reformat to be more consistent with existing code. Fix a few typos. add missing paramter - macro seemingly unused, but absence results in compiler complaint fix reference; move declaration in file Remove unused debugging print in '#if 0' block Fix typo. Fix CHECK of wrong ID (dset[2|3]_id). change test file name and apply 'h5_fixname' to it Sidestep and hide&flag minor issues causing test failures. Incorporate minimized dset ohdr tests into extant suite. ...
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 1526eca..8ed10a4 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -52,8 +52,8 @@ check_SCRIPTS = $(TEST_SCRIPT)
# As an exception, long-running tests should occur earlier in the list.
# This gives them more time to run when tests are executing in parallel.
TEST_PROG= testhdf5 \
- cache cache_api cache_image cache_tagging lheap ohdr stab gheap \
- evict_on_close farray earray btree2 fheap \
+ cache cache_api cache_image cache_tagging lheap ohdr \
+ stab gheap evict_on_close farray earray btree2 fheap \
pool accum hyperslab istore bittests dt_arith page_buffer \
dtypes dsets cmpd_dset filter_fail extend direct_chunk external efc \
objcopy links unlink twriteorder big mtime fillval mount \
@@ -177,6 +177,7 @@ CHECK_CLEANFILES+=accum.h5 cmpd_dset.h5 compact_dataset.h5 dataset.h5 dset_offse
extend.h5 istore.h5 extlinks*.h5 frspace.h5 links*.h5 \
sys_file1 tfile[1-7].h5 th5s[1-4].h5 lheap.h5 fheap.h5 ohdr.h5 \
stab.h5 extern_[1-5].h5 extern_[1-4][rw].raw gheap[0-4].h5 \
+ ohdr_min_a.h5 ohdr_min_b.h5 min_dset_ohdr_testfile.h5\
dt_arith[1-2] links.h5 links[0-6]*.h5 extlinks[0-15].h5 tmp \
big.data big[0-9][0-9][0-9][0-9][0-9].h5 \
stdio.h5 sec2.h5 dtypes[0-9].h5 dtypes1[0].h5 dt_arith[1-2].h5 tattr.h5 \