summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-09-13 22:30:33 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-09-13 22:30:33 (GMT)
commit33beeb7f55193bc76a7544f9fe3634718f36352d (patch)
tree477997f046cf9bc98025a8ecdd63ea01963d1081 /test/Makefile.am
parent676e9e6f13caaeff5fb0e3809dda6d0e427bf0de (diff)
downloadhdf5-33beeb7f55193bc76a7544f9fe3634718f36352d.zip
hdf5-33beeb7f55193bc76a7544f9fe3634718f36352d.tar.gz
hdf5-33beeb7f55193bc76a7544f9fe3634718f36352d.tar.bz2
[svn-r11411] Purpose:
Bug fix Description: Building with --disable-static seems to have been broken on several platforms. Fixed this. Configure will now disable shared libraries automatically when using pgf90 or when building on Cygwin. Solution: To avoid errors when using shared libraries with pgf90 (which I had not realized were compiler-specific), I had manually set convenience libraries to use the -static linking flag. Apparently, this is not necessary, and caused these libraries to be created as empty archives when --disable-static was used. Also, some libraries were including other libraries, which was not necessary. I also fixed code in configure.in to correctly detect whether shared or static libraries are enabled, and moved code that disables shared libraries to before libtool is created (rather than editing libtool after the fact). Despite repeated warnings that only one shared library can be linked at a time, I have yet to have shared libraries break the linking of tests on any system. We'll see if the Daily Tests turn up anything. Platforms tested: mir (fortran, C++), sleipnir (C++), modi4 (fortran, C++, parallel), sol (fortran, C++), cygwin
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 1 insertions, 7 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 3fa1690..cb5eb38 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -48,14 +48,8 @@ check_PROGRAMS=$(TEST_PROG) error_test err_compat testmeta
# The libh5test library provides common support code for the tests.
-check_LTLIBRARIES=libh5test.la
+noinst_LTLIBRARIES=libh5test.la
libh5test_la_SOURCES=h5test.c testframe.c
-libh5test_la_LIBADD=$(LIBHDF5)
-
-# Build the library statically because some compilers can only link
-# one dynamic library and the main hdf5 library is much larger than this
-# one.
-libh5test_la_LDFLAGS=-static
# Use libhd5test.la to compile all of the tests
LDADD=libh5test.la $(LIBHDF5)