summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-10-20 21:36:24 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-10-20 21:36:24 (GMT)
commitcf7631c80cb8bd2a6b089dfce94102d219c358da (patch)
tree64c062675006b9bd1d21c1fbaba667257e8cf260 /test/Makefile.am
parentc997f29d608d71d39ad61ddb241f1459f2670983 (diff)
downloadhdf5-cf7631c80cb8bd2a6b089dfce94102d219c358da.zip
hdf5-cf7631c80cb8bd2a6b089dfce94102d219c358da.tar.gz
hdf5-cf7631c80cb8bd2a6b089dfce94102d219c358da.tar.bz2
[svn-r11590] Purpose:
Bug fix Description: test/gen_new_fill.c used some old APIs that didn't compile with the current library. Brought it up-to-date. Some other files (test/gen_old_*) are designed to be compiled only with older versions of the library. Removed rules to try to build them in the current Makefiles. Platforms tested: mir
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 365d5be..f4e986d 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -52,10 +52,11 @@ check_PROGRAMS=$(TEST_PROG) error_test err_compat testmeta
# them in a conditional causes automake to generate rules so that they
# can be built by hand. They can also be built by specifying
# --enable-build-all at configure time.
+# The gen_old_* files can only be compiled with older versions of the library
+# so do not appear in this list.
if BUILD_ALL_CONDITIONAL
BUILD_ALL_PROGS=gen_deflate gen_filters gen_new_array gen_new_fill \
- gen_new_mtime gen_new_super gen_noencoder gen_nullspace \
- gen_old_array gen_old_layout gen_old_mtime
+ gen_new_mtime gen_new_super gen_noencoder gen_nullspace
else
BUILD_ALL_PROGS=
endif