summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2020-01-30 20:10:07 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-05-20 14:31:54 (GMT)
commit66334f899d19edc01cf83bebbc6dcec914b3dfa3 (patch)
tree6372249a23e69edac0764889fdddb27d75385632 /test/Makefile.am
parentd21d9aa1fb6823a4695edea4a55a71b4de7fddb9 (diff)
downloadhdf5-66334f899d19edc01cf83bebbc6dcec914b3dfa3.zip
hdf5-66334f899d19edc01cf83bebbc6dcec914b3dfa3.tar.gz
hdf5-66334f899d19edc01cf83bebbc6dcec914b3dfa3.tar.bz2
Temporarily add some code that measures the time to run the simplest possible
H5T__copy_all()-like routine 10 million times and then measures the version with FUNC_ENTER_STATIC/_LEAVE_NOAPI and a HGOTO_ERROR() statement.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 4e95641..0be011f 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -155,6 +155,8 @@ libh5test_la_SOURCES=h5test.c testframe.c cache_common.c swmr_common.c external_
# Use libhd5test.la to compile all of the tests
LDADD=libh5test.la $(LIBHDF5)
+dtypes_SOURCES=dtypes.c nop.c
+
# List the source files for tests that have more than one
ttsafe_SOURCES=ttsafe.c ttsafe_dcreate.c ttsafe_error.c ttsafe_cancel.c \
ttsafe_acreate.c