summaryrefslogtreecommitdiffstats
path: root/testpar/API/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-05-05 20:57:40 (GMT)
committerGitHub <noreply@github.com>2023-05-05 20:57:40 (GMT)
commit4b228ec6af3c53956fba7822c0ae808d3d3e2cb3 (patch)
tree134559dc3c077697845f0158e9da73162210ff2f /testpar/API/CMakeLists.txt
parentcc4d63b026dd0c392adc28e90a14eec47cb10bdd (diff)
downloadhdf5-4b228ec6af3c53956fba7822c0ae808d3d3e2cb3.zip
hdf5-4b228ec6af3c53956fba7822c0ae808d3d3e2cb3.tar.gz
hdf5-4b228ec6af3c53956fba7822c0ae808d3d3e2cb3.tar.bz2
Fix CMake generator expression syntax (#2909)
Diffstat (limited to 'testpar/API/CMakeLists.txt')
-rw-r--r--testpar/API/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/testpar/API/CMakeLists.txt b/testpar/API/CMakeLists.txt
index e907078..f893f0c 100644
--- a/testpar/API/CMakeLists.txt
+++ b/testpar/API/CMakeLists.txt
@@ -94,7 +94,7 @@ target_compile_options (
target_compile_definitions (
h5_api_test_parallel
PRIVATE
- $<$<CONFIG:Developer>:${HDF5_DEVELOPER_DEFS}>
+ "$<$<CONFIG:Developer>:${HDF5_DEVELOPER_DEFS}>"
)
if (NOT BUILD_SHARED_LIBS)
TARGET_C_PROPERTIES (h5_api_test_parallel STATIC)
@@ -173,7 +173,7 @@ foreach (api_test_extra ${HDF5_API_PAR_TESTS_EXTRA})
target_compile_definitions (
h5_api_test_parallel_${api_test_extra}
PRIVATE
- $<$<CONFIG:Developer>:${HDF5_DEVELOPER_DEFS}>
+ "$<$<CONFIG:Developer>:${HDF5_DEVELOPER_DEFS}>"
)
if (NOT BUILD_SHARED_LIBS)
TARGET_C_PROPERTIES (h5_api_test_parallel_${api_test_extra} STATIC)