summaryrefslogtreecommitdiffstats
path: root/testpar/API/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-05-03 16:45:16 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2023-05-03 18:26:57 (GMT)
commit7df92eee39e904bb38e74ce5f7971ebc4886472b (patch)
treee15ab5693fa57f2a873173f1631d4515b77e6825 /testpar/API/CMakeLists.txt
parentc75b4af1a2630ace445da1ec661191601583f79a (diff)
downloadhdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.zip
hdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.tar.gz
hdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.tar.bz2
Changes to isolate API Test option files and use fetchcontent (#2880)
Diffstat (limited to 'testpar/API/CMakeLists.txt')
-rw-r--r--testpar/API/CMakeLists.txt27
1 files changed, 21 insertions, 6 deletions
diff --git a/testpar/API/CMakeLists.txt b/testpar/API/CMakeLists.txt
index 5eb69c4..e907078 100644
--- a/testpar/API/CMakeLists.txt
+++ b/testpar/API/CMakeLists.txt
@@ -9,16 +9,31 @@
# help@hdfgroup.org.
#
-#------------------------------------------------------------------------------
-# Set module path
-#------------------------------------------------------------------------------
-set(HDF5_TEST_API_CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/CMake")
-set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${HDF5_TEST_API_CMAKE_MODULE_PATH})
+cmake_minimum_required (VERSION 3.18)
+project (HDF5_TEST_PAR_API C)
#------------------------------------------------------------------------------
-# Setup for API tests
+# Define for API tests
#------------------------------------------------------------------------------
+set (HDF5_API_TESTS
+ attribute
+ dataset
+ datatype
+ file
+ group
+ link
+ misc
+ object
+)
+
+if (HDF5_TEST_API_ENABLE_ASYNC)
+ set (HDF5_API_TESTS
+ ${HDF5_API_TESTS}
+ async
+ )
+endif ()
+
# Ported HDF5 tests
set (HDF5_API_PAR_TESTS_EXTRA
t_bigio