summaryrefslogtreecommitdiffstats
path: root/testpar/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Henderson <jhenderson@hdfgroup.org>2018-07-27 19:58:01 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2018-07-27 19:58:01 (GMT)
commitd075c0854d1ffb5a8eae23c5eb9a4456067f30c9 (patch)
treea12ca96600ceef817e2c99e3cad2712a010a17a7 /testpar/CMakeLists.txt
parent272eb4b8bffd2ab732d268c421583587317b8dc2 (diff)
downloadhdf5-d075c0854d1ffb5a8eae23c5eb9a4456067f30c9.zip
hdf5-d075c0854d1ffb5a8eae23c5eb9a4456067f30c9.tar.gz
hdf5-d075c0854d1ffb5a8eae23c5eb9a4456067f30c9.tar.bz2
Add quotes to places where MPI_C_LIBRARIES are linked against
Diffstat (limited to 'testpar/CMakeLists.txt')
-rw-r--r--testpar/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/testpar/CMakeLists.txt b/testpar/CMakeLists.txt
index e843811..c08a69e 100644
--- a/testpar/CMakeLists.txt
+++ b/testpar/CMakeLists.txt
@@ -26,7 +26,7 @@ target_include_directories(testphdf5
)
TARGET_C_PROPERTIES (testphdf5 STATIC)
target_link_libraries (testphdf5
- PRIVATE ${HDF5_TEST_LIB_TARGET} ${HDF5_LIB_TARGET} $<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>
+ PRIVATE ${HDF5_TEST_LIB_TARGET} ${HDF5_LIB_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>"
)
set_target_properties (testphdf5 PROPERTIES FOLDER test/par)
@@ -37,7 +37,7 @@ MACRO (ADD_H5P_EXE file)
)
TARGET_C_PROPERTIES (${file} STATIC)
target_link_libraries (${file}
- PRIVATE ${HDF5_TEST_LIB_TARGET} ${HDF5_LIB_TARGET} $<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>
+ PRIVATE ${HDF5_TEST_LIB_TARGET} ${HDF5_LIB_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>"
)
set_target_properties (${file} PROPERTIES FOLDER test/par)
ENDMACRO (ADD_H5P_EXE file)