summaryrefslogtreecommitdiffstats
path: root/testpar/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-09-30 14:28:21 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-09-30 14:28:21 (GMT)
commitca0c0c3dc83acb7261e607cfee3b3ef04d167188 (patch)
tree6aa9407c7a4cb1bd10975205c14ff8b1ce3f0d5e /testpar/CMakeLists.txt
parent636cba89e605644c8f094fcc7f951c70cd895a39 (diff)
downloadhdf5-ca0c0c3dc83acb7261e607cfee3b3ef04d167188.zip
hdf5-ca0c0c3dc83acb7261e607cfee3b3ef04d167188.tar.gz
hdf5-ca0c0c3dc83acb7261e607cfee3b3ef04d167188.tar.bz2
Merge of clang-format changes from develop
Diffstat (limited to 'testpar/CMakeLists.txt')
-rw-r--r--testpar/CMakeLists.txt18
1 files changed, 16 insertions, 2 deletions
diff --git a/testpar/CMakeLists.txt b/testpar/CMakeLists.txt
index dba9e68..9f4ce88 100644
--- a/testpar/CMakeLists.txt
+++ b/testpar/CMakeLists.txt
@@ -39,7 +39,14 @@ else ()
endif ()
set_target_properties (testphdf5 PROPERTIES FOLDER test/par)
-MACRO (ADD_H5P_EXE file)
+#-----------------------------------------------------------------------------
+# Add Target to clang-format
+#-----------------------------------------------------------------------------
+if (HDF5_ENABLE_FORMATTERS)
+ clang_format (HDF5_TEST_PAR_testphdf5_FORMAT testphdf5)
+endif ()
+
+macro (ADD_H5P_EXE file)
add_executable (${file} ${HDF5_TEST_PAR_SOURCE_DIR}/${file}.c)
target_compile_options(${file} PRIVATE "${HDF5_CMAKE_C_FLAGS}")
target_include_directories (${file}
@@ -59,7 +66,14 @@ MACRO (ADD_H5P_EXE file)
)
endif ()
set_target_properties (${file} PROPERTIES FOLDER test/par)
-ENDMACRO (ADD_H5P_EXE file)
+
+ #-----------------------------------------------------------------------------
+ # Add Target to clang-format
+ #-----------------------------------------------------------------------------
+ if (HDF5_ENABLE_FORMATTERS)
+ clang_format (HDF5_TEST_PAR_${file}_FORMAT ${file})
+ endif ()
+endmacro (ADD_H5P_EXE file)
set (H5P_TESTS
t_mpi