summaryrefslogtreecommitdiffstats
path: root/testpar/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-05-03 16:45:16 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2023-05-03 18:26:57 (GMT)
commit7df92eee39e904bb38e74ce5f7971ebc4886472b (patch)
treee15ab5693fa57f2a873173f1631d4515b77e6825 /testpar/CMakeLists.txt
parentc75b4af1a2630ace445da1ec661191601583f79a (diff)
downloadhdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.zip
hdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.tar.gz
hdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.tar.bz2
Changes to isolate API Test option files and use fetchcontent (#2880)
Diffstat (limited to 'testpar/CMakeLists.txt')
-rw-r--r--testpar/CMakeLists.txt24
1 files changed, 4 insertions, 20 deletions
diff --git a/testpar/CMakeLists.txt b/testpar/CMakeLists.txt
index d34b800..6bb5fa6 100644
--- a/testpar/CMakeLists.txt
+++ b/testpar/CMakeLists.txt
@@ -104,30 +104,14 @@ set (H5P_TESTS
t_vfd
)
-set (HDF5_API_TESTS
- attribute
- dataset
- datatype
- file
- group
- link
- misc
- object
-)
-
-if (HDF5_TEST_API_ENABLE_ASYNC)
- set (HDF5_API_TESTS
- ${HDF5_API_TESTS}
- async
- )
-endif ()
-
foreach (h5_testp ${H5P_TESTS})
ADD_H5P_EXE(${h5_testp})
endforeach ()
-add_subdirectory (API)
-
if (HDF5_TEST_PARALLEL)
include (CMakeTests.cmake)
endif ()
+
+if (HDF5_TEST_API)
+ add_subdirectory (API)
+endif ()