summaryrefslogtreecommitdiffstats
path: root/testpar/CMakeLists.txt
diff options
context:
space:
mode:
authorjhendersonHDF <jhenderson@hdfgroup.org>2023-05-02 19:52:39 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2023-05-03 18:26:57 (GMT)
commitc75b4af1a2630ace445da1ec661191601583f79a (patch)
treea345b94dc09dd1ea1c38c1136a133b00939ba395 /testpar/CMakeLists.txt
parent75d64819b050bb30b2a2751d9ba55651f9a1af79 (diff)
downloadhdf5-c75b4af1a2630ace445da1ec661191601583f79a.zip
hdf5-c75b4af1a2630ace445da1ec661191601583f79a.tar.gz
hdf5-c75b4af1a2630ace445da1ec661191601583f79a.tar.bz2
Add initial version of HDF5 API tests (#2877)
Diffstat (limited to 'testpar/CMakeLists.txt')
-rw-r--r--testpar/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/testpar/CMakeLists.txt b/testpar/CMakeLists.txt
index 3a44fca..d34b800 100644
--- a/testpar/CMakeLists.txt
+++ b/testpar/CMakeLists.txt
@@ -104,10 +104,30 @@ set (H5P_TESTS
t_vfd
)
+set (HDF5_API_TESTS
+ attribute
+ dataset
+ datatype
+ file
+ group
+ link
+ misc
+ object
+)
+
+if (HDF5_TEST_API_ENABLE_ASYNC)
+ set (HDF5_API_TESTS
+ ${HDF5_API_TESTS}
+ async
+ )
+endif ()
+
foreach (h5_testp ${H5P_TESTS})
ADD_H5P_EXE(${h5_testp})
endforeach ()
+add_subdirectory (API)
+
if (HDF5_TEST_PARALLEL)
include (CMakeTests.cmake)
endif ()