summaryrefslogtreecommitdiffstats
path: root/testpar/CMakeLists.txt
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2019-09-04 07:09:35 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2019-09-04 07:09:35 (GMT)
commit339bf241bebfc7b9634e1880899acc23b055949a (patch)
treeccc79bc92d7b6c62752bc0036a2e599f75b7deda /testpar/CMakeLists.txt
parent714804b28018c8096f65debbbb9f57f7dab2a7f6 (diff)
parentb1dab421dec1b7be64ef2c804a7e0e9b68630fc9 (diff)
downloadhdf5-339bf241bebfc7b9634e1880899acc23b055949a.zip
hdf5-339bf241bebfc7b9634e1880899acc23b055949a.tar.gz
hdf5-339bf241bebfc7b9634e1880899acc23b055949a.tar.bz2
Merge branch 'develop' of https://bitbucket.hdfgroup.org/scm/~bmribler/hdf5-bmr into develop
Diffstat (limited to 'testpar/CMakeLists.txt')
-rw-r--r--testpar/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/testpar/CMakeLists.txt b/testpar/CMakeLists.txt
index 1aecef6..51c3420 100644
--- a/testpar/CMakeLists.txt
+++ b/testpar/CMakeLists.txt
@@ -47,11 +47,13 @@ MACRO (ADD_H5P_EXE file)
TARGET_C_PROPERTIES (${file} STATIC)
target_link_libraries (${file}
PRIVATE ${HDF5_TEST_LIB_TARGET} ${HDF5_LIB_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>"
+ $<$<OR:$<PLATFORM_ID:Windows>,$<PLATFORM_ID:MinGW>>:ws2_32.lib>
)
else ()
TARGET_C_PROPERTIES (${file} SHARED)
target_link_libraries (${file}
PRIVATE ${HDF5_TEST_LIBSH_TARGET} ${HDF5_LIBSH_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>"
+ $<$<OR:$<PLATFORM_ID:Windows>,$<PLATFORM_ID:MinGW>>:ws2_32.lib>
)
endif ()
set_target_properties (${file} PROPERTIES FOLDER test/par)
@@ -61,7 +63,7 @@ set (H5P_TESTS
t_mpi
t_bigio
t_cache
- #t_cache_image
+ t_cache_image
t_pflush1
t_pflush2
t_pread