summaryrefslogtreecommitdiffstats
path: root/testpar/Makefile.am
diff options
context:
space:
mode:
authorMohamad Chaarawi <chaarawi@hdfgroup.org>2015-06-10 14:10:30 (GMT)
committerMohamad Chaarawi <chaarawi@hdfgroup.org>2015-06-10 14:10:30 (GMT)
commit5ec5c1dd65c55d4e00545c41a39feaae072e323f (patch)
tree9890a14eec503ffb853da68ae5ce7fdc3f3800c4 /testpar/Makefile.am
parent56c9297a5a7214db76dae8efdbbb2495e94f68b2 (diff)
downloadhdf5-5ec5c1dd65c55d4e00545c41a39feaae072e323f.zip
hdf5-5ec5c1dd65c55d4e00545c41a39feaae072e323f.tar.gz
hdf5-5ec5c1dd65c55d4e00545c41a39feaae072e323f.tar.bz2
[svn-r27179] Merge 27162 & 27163 from trunk:
fix for HDFFV-9412: - Check for mpi is_initialized and is_finalized before making MPI calls in init/terminate of HDF5. - Add a test to make sure we can make serial HDF5 calls from rank 0 after MPI_Finalize is called. tested with h5committest
Diffstat (limited to 'testpar/Makefile.am')
-rw-r--r--testpar/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/testpar/Makefile.am b/testpar/Makefile.am
index c79a609..b190ce8 100644
--- a/testpar/Makefile.am
+++ b/testpar/Makefile.am
@@ -25,7 +25,7 @@ AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test
# Test programs. These are our main targets.
#
-TEST_PROG_PARA=t_mpi testphdf5 t_cache t_pflush1 t_pflush2 t_pshutdown t_prestart t_shapesame
+TEST_PROG_PARA=t_mpi testphdf5 t_cache t_pflush1 t_pflush2 t_pshutdown t_prestart t_init_term t_shapesame
check_PROGRAMS = $(TEST_PROG_PARA)
@@ -39,7 +39,8 @@ LDADD = $(LIBH5TEST) $(LIBHDF5)
# MPItest.h5 is from t_mpi
# Para*.h5 are from testphdf
# shutdown.h5 is from t_pshutdown
+# after_mpi_fin.h5 is from t_init_term
# go is used for debugging. See testphdf5.c.
-CHECK_CLEANFILES+=MPItest.h5 Para*.h5 CacheTestDummy.h5 shutdown.h5 go
+CHECK_CLEANFILES+=MPItest.h5 Para*.h5 CacheTestDummy.h5 shutdown.h5 after_mpi_fin.h5 go
include $(top_srcdir)/config/conclude.am