summaryrefslogtreecommitdiffstats
path: root/testpar/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2005-08-30 04:35:17 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2005-08-30 04:35:17 (GMT)
commit3182a8a040b463629fd9f266b6a1eda6ce70c3d7 (patch)
treedb107c21fe8ae27e83b05686fd919dd44c0c12b6 /testpar/Makefile.am
parentbd4312d0497592a665a25415ec2f9d3db9d9f6b2 (diff)
downloadhdf5-3182a8a040b463629fd9f266b6a1eda6ce70c3d7.zip
hdf5-3182a8a040b463629fd9f266b6a1eda6ce70c3d7.tar.gz
hdf5-3182a8a040b463629fd9f266b6a1eda6ce70c3d7.tar.bz2
[svn-r11312] Purpose:
Bug #281 Description: A dataset created in serial mode with H5D_ALLOC_TIME_INCR allocation setting was not extendible, either explicitly by H5Dextend or implicitly by writing to unallocated chunks. This was because parallel mode expects the allocation mode be H5D_ALLOC_TIME_INCR only. Solution: Modified library to allocate more space when needed or directed if the file is opened by parallel mode, independent of what the dataset allocation mode is. Platforms tested: Heping pp.
Diffstat (limited to 'testpar/Makefile.am')
-rw-r--r--testpar/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/testpar/Makefile.am b/testpar/Makefile.am
index 92985b8..7c4f567 100644
--- a/testpar/Makefile.am
+++ b/testpar/Makefile.am
@@ -31,7 +31,7 @@ check_PROGRAMS = $(TEST_PROG_PARA)
check_SCRIPTS= $(TEST_SCRIPT)
testphdf5_SOURCES=testphdf5.c t_dset.c t_file.c t_mdset.c t_ph5basic.c \
- t_coll_chunk.c t_span_tree.c
+ t_coll_chunk.c t_span_tree.c t_chunk_alloc.c
# The tests all depend on the hdf5 library and the test library
LDADD = $(LIBHDF5) $(LIBH5TEST)