summaryrefslogtreecommitdiffstats
path: root/testpar/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-06-30 23:35:32 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-06-30 23:35:32 (GMT)
commit43f091f462202a84a863f000582e75fd6c04e6f4 (patch)
tree00bd95eeb9f866516324e4481a78174e6628d651 /testpar/Makefile.am
parentafcd1ddb398e04006da8b11a95a60cec61da7349 (diff)
downloadhdf5-43f091f462202a84a863f000582e75fd6c04e6f4.zip
hdf5-43f091f462202a84a863f000582e75fd6c04e6f4.tar.gz
hdf5-43f091f462202a84a863f000582e75fd6c04e6f4.tar.bz2
[svn-r11008] Purpose:
Feature: tests now use parallel make and only run once Description: When make is invoked in parallel (using the -j option), several tests will now be run simultaneously. This should speed up testing on a number of systems. When a test passes, it creates a foo.chkexe or foo.chksh file, which prevents the test from running again unless the test or library changes. Solution: Most of the changes live in config/conclude.am. Added *.chkexe and *.chksh files to the list of files to be cleaned at "make mostlyclean" time. Parallel tests still run one at a time, but use the same make instructions as serial tests. Platforms tested: mir, eirene, sleipnir, pommier, copper, modi4 (some errors occurred, probably due to the test being run before updating hdf5. Will re-run tests after checkin.)
Diffstat (limited to 'testpar/Makefile.am')
-rw-r--r--testpar/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/testpar/Makefile.am b/testpar/Makefile.am
index 56ccfef..b11678c 100644
--- a/testpar/Makefile.am
+++ b/testpar/Makefile.am
@@ -40,7 +40,7 @@ LDADD = $(LIBHDF5) $(LIBH5TEST)
# MPItest.h5 is from t_mpi
# Para*.h5 are from testphdf
# *.clog are from MPE option
-MOSTLYCLEANFILES=MPItest.h5 Para*.h5 *.clog
+MOSTLYCLEANFILES+=MPItest.h5 Para*.h5 *.clog
DISTCLEANFILES=go Makefile testph5.sh
include $(top_srcdir)/config/conclude.am