summaryrefslogtreecommitdiffstats
path: root/testpar/Makefile.am
diff options
context:
space:
mode:
authorMohamad Chaarawi <chaarawi@hdfgroup.org>2015-06-08 20:52:48 (GMT)
committerMohamad Chaarawi <chaarawi@hdfgroup.org>2015-06-08 20:52:48 (GMT)
commit929e8ce1281a2a4953f6f3925a8595227fcb8f7f (patch)
tree5a6e2ad3622dadf6de58ce81397328e527fbd1c7 /testpar/Makefile.am
parent02e9a43900cb8d2879b9bb2af9c3a9aba98c8949 (diff)
downloadhdf5-929e8ce1281a2a4953f6f3925a8595227fcb8f7f.zip
hdf5-929e8ce1281a2a4953f6f3925a8595227fcb8f7f.tar.gz
hdf5-929e8ce1281a2a4953f6f3925a8595227fcb8f7f.tar.bz2
[svn-r27162] fix for HDFFV-9412:
- Check for mpi is_initialized and is_finalized before making MPI calls in init/terminate of HDF5. - Add a test to make sure we can make serial HDF5 calls from rank 0 after MPI_Finalize is called. tested with h5committest
Diffstat (limited to 'testpar/Makefile.am')
-rw-r--r--testpar/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/testpar/Makefile.am b/testpar/Makefile.am
index 1eae439..4fe0ba8 100644
--- a/testpar/Makefile.am
+++ b/testpar/Makefile.am
@@ -25,7 +25,7 @@ AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test
# Test programs. These are our main targets.
#
-TEST_PROG_PARA=t_mpi testphdf5 t_cache t_pflush1 t_pflush2 t_pshutdown t_prestart t_shapesame
+TEST_PROG_PARA=t_mpi testphdf5 t_cache t_pflush1 t_pflush2 t_pshutdown t_prestart t_init_term t_shapesame
check_PROGRAMS = $(TEST_PROG_PARA)
@@ -40,7 +40,8 @@ LDADD = $(LIBH5TEST) $(LIBHDF5)
# MPItest.h5 is from t_mpi
# Para*.h5 are from testphdf
# shutdown.h5 is from t_pshutdown
+# after_mpi_fin.h5 is from t_init_term
# go is used for debugging. See testphdf5.c.
-CHECK_CLEANFILES+=MPItest.h5 Para*.h5 CacheTestDummy.h5 shutdown.h5 go
+CHECK_CLEANFILES+=MPItest.h5 Para*.h5 CacheTestDummy.h5 shutdown.h5 after_mpi_fin.h5 go
include $(top_srcdir)/config/conclude.am