summaryrefslogtreecommitdiffstats
path: root/testpar/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-01 03:17:02 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-01 03:17:02 (GMT)
commit26303241febadd20aea77fc8a1d48f05823170af (patch)
tree4ba1d92050fa6cc33feab6a38bc9778f71bbb146 /testpar/Makefile.am
parent9f17319144fca94a852fd500487b0e4ae48e0997 (diff)
downloadhdf5-26303241febadd20aea77fc8a1d48f05823170af.zip
hdf5-26303241febadd20aea77fc8a1d48f05823170af.tar.gz
hdf5-26303241febadd20aea77fc8a1d48f05823170af.tar.bz2
[svn-r9902] Purpose:
Configuration feature Description: HDF5 now uses automake to generate Makefiles Solution: Makefile.in files are now generated from Makefile.am files. To reconfigure (after chaning a Makefile.am or configure.in): /bin/sh bin/reconfigure.sh Platforms tested: Many
Diffstat (limited to 'testpar/Makefile.am')
-rw-r--r--testpar/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/testpar/Makefile.am b/testpar/Makefile.am
new file mode 100644
index 0000000..0466a66
--- /dev/null
+++ b/testpar/Makefile.am
@@ -0,0 +1,46 @@
+#
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdf.ncsa.uiuc.edu/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from hdfhelp@ncsa.uiuc.edu.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+##
+#
+# hdf5 Parallel Library Test Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+AM_CFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/test
+
+# Test programs and scripts. These are our main targets.
+#
+TEST_PROG_PARA=t_mpi t_fphdf5 testphdf5
+TEST_SCRIPT=testph5.sh
+
+check_PROGRAMS = $(TEST_PROG_PARA)
+check_SCRIPTS= $(TEST_SCRIPT)
+
+testphdf5_SOURCES=testphdf5.c t_dset.c t_file.c t_mdset.c t_ph5basic.c \
+ t_coll_chunk.c t_span_tree.c
+
+# The tests all depend on the hdf5 library and the test library
+LDADD = $(LIBHDF5) $(LIBH5TEST)
+
+# Temporary files
+# MPItest.h5 is from t_mpi
+# Para*.h5 are from testphdf
+# *.clog are from MPE option
+MOSTLYCLEANFILES=MPItest.h5 Para*.h5 *.clog
+DISTCLEANFILES=go Makefile testph5.sh
+
+include $(top_srcdir)/config/conclude.am