summaryrefslogtreecommitdiffstats
path: root/testpar/Makefile.am
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2010-07-19 08:09:49 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2010-07-19 08:09:49 (GMT)
commit1ff6aff53dacca3afaa96ad959c857693ea6f6d6 (patch)
treeb5592c43a2e492fe039f0f8361dc6acfc83456a2 /testpar/Makefile.am
parentcf6e2c99a43cd794e85ac8e23fee2e45a35d9121 (diff)
downloadhdf5-1ff6aff53dacca3afaa96ad959c857693ea6f6d6.zip
hdf5-1ff6aff53dacca3afaa96ad959c857693ea6f6d6.tar.gz
hdf5-1ff6aff53dacca3afaa96ad959c857693ea6f6d6.tar.bz2
[svn-r19093] Description:
Bring r19092 from trunk to 1.8 branch: Bring "shape same" changes from LBL branch to trunk. These changes allow shapes that are the same, but projected into dataspaces with different ranks to be detected correctly, and also contains code to project a dataspace into greater/lesser number of dimensions, so the I/O can proceed in a faster way. These changes also contain several bug fixes and _lots_ of code cleanups to the MPI datatype creation code. Many other misc. code cleanup are included as well... Tested on: FreeBSD/32 6.3 (duty) in debug mode FreeBSD/64 6.3 (liberty) w/C++ & FORTRAN, in debug mode (h5committested on trunk)
Diffstat (limited to 'testpar/Makefile.am')
-rw-r--r--testpar/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/testpar/Makefile.am b/testpar/Makefile.am
index 3c39989..6e76e88 100644
--- a/testpar/Makefile.am
+++ b/testpar/Makefile.am
@@ -32,7 +32,8 @@ check_PROGRAMS = $(TEST_PROG_PARA)
check_SCRIPTS= $(TEST_SCRIPT)
testphdf5_SOURCES=testphdf5.c t_dset.c t_file.c t_mdset.c t_ph5basic.c \
- t_coll_chunk.c t_span_tree.c t_chunk_alloc.c t_filter_read.c
+ t_coll_chunk.c t_span_tree.c t_chunk_alloc.c t_filter_read.c \
+ t_rank_projection.c
# The tests all depend on the hdf5 library and the test library
LDADD = $(LIBH5TEST) $(LIBHDF5)