summaryrefslogtreecommitdiffstats
path: root/testpar/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-09-13 22:30:33 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-09-13 22:30:33 (GMT)
commit33beeb7f55193bc76a7544f9fe3634718f36352d (patch)
tree477997f046cf9bc98025a8ecdd63ea01963d1081 /testpar/Makefile.am
parent676e9e6f13caaeff5fb0e3809dda6d0e427bf0de (diff)
downloadhdf5-33beeb7f55193bc76a7544f9fe3634718f36352d.zip
hdf5-33beeb7f55193bc76a7544f9fe3634718f36352d.tar.gz
hdf5-33beeb7f55193bc76a7544f9fe3634718f36352d.tar.bz2
[svn-r11411] Purpose:
Bug fix Description: Building with --disable-static seems to have been broken on several platforms. Fixed this. Configure will now disable shared libraries automatically when using pgf90 or when building on Cygwin. Solution: To avoid errors when using shared libraries with pgf90 (which I had not realized were compiler-specific), I had manually set convenience libraries to use the -static linking flag. Apparently, this is not necessary, and caused these libraries to be created as empty archives when --disable-static was used. Also, some libraries were including other libraries, which was not necessary. I also fixed code in configure.in to correctly detect whether shared or static libraries are enabled, and moved code that disables shared libraries to before libtool is created (rather than editing libtool after the fact). Despite repeated warnings that only one shared library can be linked at a time, I have yet to have shared libraries break the linking of tests on any system. We'll see if the Daily Tests turn up anything. Platforms tested: mir (fortran, C++), sleipnir (C++), modi4 (fortran, C++, parallel), sol (fortran, C++), cygwin
Diffstat (limited to 'testpar/Makefile.am')
-rw-r--r--testpar/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/testpar/Makefile.am b/testpar/Makefile.am
index 5c66da1..12921ff 100644
--- a/testpar/Makefile.am
+++ b/testpar/Makefile.am
@@ -34,7 +34,7 @@ testphdf5_SOURCES=testphdf5.c t_dset.c t_file.c t_mdset.c t_ph5basic.c \
t_coll_chunk.c t_span_tree.c t_chunk_alloc.c
# The tests all depend on the hdf5 library and the test library
-LDADD = $(LIBHDF5) $(LIBH5TEST)
+LDADD = $(LIBH5TEST) $(LIBHDF5)
# Temporary files
# MPItest.h5 is from t_mpi