summaryrefslogtreecommitdiffstats
path: root/testpar/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2011-01-12 04:38:59 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2011-01-12 04:38:59 (GMT)
commit2f54a4ba53f86369d912dd73f3ccfb9055aa36ca (patch)
tree0c2ccbb29d6e2bb3dedec4d618e872874e672f53 /testpar/Makefile.am
parent38f18282ba6f66e45e64cdd11e942ea86e0b3496 (diff)
downloadhdf5-2f54a4ba53f86369d912dd73f3ccfb9055aa36ca.zip
hdf5-2f54a4ba53f86369d912dd73f3ccfb9055aa36ca.tar.gz
hdf5-2f54a4ba53f86369d912dd73f3ccfb9055aa36ca.tar.bz2
[svn-r19941] Purpose:
Moved the two shape same tests from testphdf5 to a separated executables, named t_shapesame. The shape same tests runs too long for testphdf5. In a separated executalbe, it will be easier to separate any errors in testphdf5 sub-tests from the shape same tests. t_shapesame.c: Contains the shape same tests (cloned from t_rank_projection.c) plus a duplicate of "testphdf5.c" for now. After verifying it is correct, more cleanup is needed. testphdf5.c: Removed the two shape same tests (chsssdrpio & cbhsssdrpio). Makefile.am: Makefile.in: Added t_shapesame as a new test executable. Removed t_rank_projections.c from part of testphdf5. testph5.sh.in: Temporary added the "t_shapesame -p" test for testing shape same tests with MPIO-Posix VFD. Tested: h5committested, plus serial jam.
Diffstat (limited to 'testpar/Makefile.am')
-rw-r--r--testpar/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/testpar/Makefile.am b/testpar/Makefile.am
index 6e76e88..5a7a3f3 100644
--- a/testpar/Makefile.am
+++ b/testpar/Makefile.am
@@ -25,15 +25,14 @@ INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/test
# Test programs and scripts. These are our main targets.
#
-TEST_PROG_PARA=t_mpi t_posix_compliant testphdf5 t_cache t_pflush1 t_pflush2
+TEST_PROG_PARA=t_mpi t_posix_compliant testphdf5 t_cache t_pflush1 t_pflush2 t_shapesame
TEST_SCRIPT_PARA=testph5.sh
check_PROGRAMS = $(TEST_PROG_PARA)
check_SCRIPTS= $(TEST_SCRIPT)
testphdf5_SOURCES=testphdf5.c t_dset.c t_file.c t_mdset.c t_ph5basic.c \
- t_coll_chunk.c t_span_tree.c t_chunk_alloc.c t_filter_read.c \
- t_rank_projection.c
+ t_coll_chunk.c t_span_tree.c t_chunk_alloc.c t_filter_read.c
# The tests all depend on the hdf5 library and the test library
LDADD = $(LIBH5TEST) $(LIBHDF5)