summaryrefslogtreecommitdiffstats
path: root/testpar/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-12-31 20:06:43 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-12-31 20:06:43 (GMT)
commit0e6cf18b06d71dc8da9307dddce5e1833f197e19 (patch)
tree615170bc289e63ab2170c11201abf7487d1a8e7e /testpar/Makefile.am
parent028d47d70791ff0ec559035df80508a084e55213 (diff)
parentb30a1fe44aa804a67f2291005bf8135ac5c2dc99 (diff)
downloadhdf5-0e6cf18b06d71dc8da9307dddce5e1833f197e19.zip
hdf5-0e6cf18b06d71dc8da9307dddce5e1833f197e19.tar.gz
hdf5-0e6cf18b06d71dc8da9307dddce5e1833f197e19.tar.bz2
Merging in latest from upstream (HDFFV/hdf5:refs/heads/develop)
* commit 'b30a1fe44aa804a67f2291005bf8135ac5c2dc99': Updated the parallel install docs. Eliminated the need for a separate script variable. Added a helpful message to the flush script. Added a shell script so we can run the parallel flush test on OpenMPI.
Diffstat (limited to 'testpar/Makefile.am')
-rw-r--r--testpar/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/testpar/Makefile.am b/testpar/Makefile.am
index 7262ca6..a11099d 100644
--- a/testpar/Makefile.am
+++ b/testpar/Makefile.am
@@ -21,11 +21,19 @@ include $(top_srcdir)/config/commence.am
AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test
+# Test scripts--
+# testpflush.sh:
+TEST_SCRIPT_PARA = testpflush.sh
+SCRIPT_DEPEND = t_pflush1$(EXEEXT) t_pflush2$(EXEEXT)
+
+check_SCRIPTS = $(TEST_SCRIPT_PARA)
+
# Test programs. These are our main targets.
#
-TEST_PROG_PARA=t_mpi t_bigio testphdf5 t_cache t_cache_image t_pflush1 t_pflush2 t_pread t_pshutdown t_prestart t_init_term t_shapesame t_filters_parallel
+TEST_PROG_PARA=t_mpi t_bigio testphdf5 t_cache t_cache_image t_pread t_pshutdown t_prestart t_init_term t_shapesame t_filters_parallel
-check_PROGRAMS = $(TEST_PROG_PARA)
+# t_pflush1 and t_pflush2 are used by testpflush.sh
+check_PROGRAMS = $(TEST_PROG_PARA) t_pflush1 t_pflush2
testphdf5_SOURCES=testphdf5.c t_dset.c t_file.c t_file_image.c t_mdset.c \
t_ph5basic.c t_coll_chunk.c t_span_tree.c t_chunk_alloc.c t_filter_read.c \