summaryrefslogtreecommitdiffstats
path: root/testpar/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2018-12-20 11:03:16 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2018-12-20 11:03:16 (GMT)
commitfe1a5b4279bbbf705c6d3b3886ffe2a963bd07ec (patch)
treea482951f2d94a0f3d4e85b65791f73c0493874af /testpar/Makefile.am
parent34c0328c4d44a26916ebe0756ad5d74ac3c1dec8 (diff)
downloadhdf5-fe1a5b4279bbbf705c6d3b3886ffe2a963bd07ec.zip
hdf5-fe1a5b4279bbbf705c6d3b3886ffe2a963bd07ec.tar.gz
hdf5-fe1a5b4279bbbf705c6d3b3886ffe2a963bd07ec.tar.bz2
Added a shell script so we can run the parallel flush test
on OpenMPI.
Diffstat (limited to 'testpar/Makefile.am')
-rw-r--r--testpar/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/testpar/Makefile.am b/testpar/Makefile.am
index 7262ca6..a11099d 100644
--- a/testpar/Makefile.am
+++ b/testpar/Makefile.am
@@ -21,11 +21,19 @@ include $(top_srcdir)/config/commence.am
AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test
+# Test scripts--
+# testpflush.sh:
+TEST_SCRIPT_PARA = testpflush.sh
+SCRIPT_DEPEND = t_pflush1$(EXEEXT) t_pflush2$(EXEEXT)
+
+check_SCRIPTS = $(TEST_SCRIPT_PARA)
+
# Test programs. These are our main targets.
#
-TEST_PROG_PARA=t_mpi t_bigio testphdf5 t_cache t_cache_image t_pflush1 t_pflush2 t_pread t_pshutdown t_prestart t_init_term t_shapesame t_filters_parallel
+TEST_PROG_PARA=t_mpi t_bigio testphdf5 t_cache t_cache_image t_pread t_pshutdown t_prestart t_init_term t_shapesame t_filters_parallel
-check_PROGRAMS = $(TEST_PROG_PARA)
+# t_pflush1 and t_pflush2 are used by testpflush.sh
+check_PROGRAMS = $(TEST_PROG_PARA) t_pflush1 t_pflush2
testphdf5_SOURCES=testphdf5.c t_dset.c t_file.c t_file_image.c t_mdset.c \
t_ph5basic.c t_coll_chunk.c t_span_tree.c t_chunk_alloc.c t_filter_read.c \