summaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorlrknox <lrknox>2018-06-07 16:04:57 (GMT)
committerlrknox <lrknox>2018-06-07 16:04:57 (GMT)
commit664186b91d9198915baca4c6dca3f7b03695d316 (patch)
tree995de8be59b4d8524753eba6b542ce4039d54c79 /tools/CMakeLists.txt
parentb8c6b68c35fa2be23ef488a1d81097ff3ed55000 (diff)
parentdeab7b25af9026e8426c9d09718540605683a873 (diff)
downloadhdf5-664186b91d9198915baca4c6dca3f7b03695d316.zip
hdf5-664186b91d9198915baca4c6dca3f7b03695d316.tar.gz
hdf5-664186b91d9198915baca4c6dca3f7b03695d316.tar.bz2
Merge branch 'hdf5_1_8_21' of https://bitbucket.hdfgroup.org/scm/~lrknox/hdf5_lrk into 1.8/master
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt26
1 files changed, 12 insertions, 14 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index c9cc21b..6a12aa0 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required (VERSION 3.2.2)
+cmake_minimum_required (VERSION 3.10)
PROJECT (HDF5_TOOLS)
#-----------------------------------------------------------------------------
@@ -14,36 +14,34 @@ INCLUDE_DIRECTORIES (${HDF5_TOOLS_SOURCE_DIR}/lib)
# --------------------------------------------------------------------
# If testing was NOT enabled, then we need to build the tools library
# --------------------------------------------------------------------
-if (NOT BUILD_TESTING)
- add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/lib)
-endif ()
+add_subdirectory (lib)
#-- Add the h5diff and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5diff)
+add_subdirectory (h5diff)
#-- Add the h5ls executable
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5ls)
+add_subdirectory (h5ls)
#-- Misc Executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/misc)
+add_subdirectory (misc)
#-- Add the h5import and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5import)
+add_subdirectory (h5import)
#-- h5Repack executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5repack)
+add_subdirectory (h5repack)
#-- Add the h5dump and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5jam)
+add_subdirectory (h5jam)
#-- Add the h5copy and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5copy)
+add_subdirectory (h5copy)
#-- Add the h5stat and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5stat)
+add_subdirectory (h5stat)
#-- Add the h5dump and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5dump)
+add_subdirectory (h5dump)
#-- Add the perform and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/perform)
+add_subdirectory (perform)