summaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-10-02 21:16:34 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-10-02 21:17:10 (GMT)
commit8c26358eca11455235df239a7e9f3a225b3141da (patch)
treef9ae4061b519ae7c516830a59a92faba93f9f006 /tools/CMakeLists.txt
parent66ef37d0d8030f38c924374facc49f6af6f6ddd5 (diff)
downloadhdf5-8c26358eca11455235df239a7e9f3a225b3141da.zip
hdf5-8c26358eca11455235df239a7e9f3a225b3141da.tar.gz
hdf5-8c26358eca11455235df239a7e9f3a225b3141da.tar.bz2
Merge CMake changes from 1.10 to 1.8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt15
1 files changed, 1 insertions, 14 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 6a12aa0..f088d3b 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -1,19 +1,6 @@
cmake_minimum_required (VERSION 3.10)
-PROJECT (HDF5_TOOLS)
+project (HDF5_TOOLS C)
-#-----------------------------------------------------------------------------
-# Apply Definitions to compiler in this directory and below
-#-----------------------------------------------------------------------------
-add_definitions (${HDF_EXTRA_C_FLAGS})
-
-#-----------------------------------------------------------------------------
-# Setup include Directories
-#-----------------------------------------------------------------------------
-INCLUDE_DIRECTORIES (${HDF5_TOOLS_SOURCE_DIR}/lib)
-
-# --------------------------------------------------------------------
-# If testing was NOT enabled, then we need to build the tools library
-# --------------------------------------------------------------------
add_subdirectory (lib)
#-- Add the h5diff and test executables