summaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2014-03-18 16:21:46 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2014-03-18 16:21:46 (GMT)
commit03d10edd23ce76e9389b54be138ef1bbb8791cef (patch)
tree97c8e0737bcb88af41df69fd7db4a23e103c6455 /tools/CMakeLists.txt
parent73a72c59b8cd243de54993f1fb0991afede4ba4d (diff)
downloadhdf5-03d10edd23ce76e9389b54be138ef1bbb8791cef.zip
hdf5-03d10edd23ce76e9389b54be138ef1bbb8791cef.tar.gz
hdf5-03d10edd23ce76e9389b54be138ef1bbb8791cef.tar.bz2
[svn-r24824] HDFFV-8700 -
KitWare recommendations: Change CMake commands to lower case. Bump up CMake minimum versions. Split test file into separate file for h5repack test. Tested: local linux
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index a9a7232..27820ae 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -15,32 +15,32 @@ INCLUDE_DIRECTORIES (${HDF5_TOOLS_SOURCE_DIR}/lib)
# If testing was NOT enabled, then we need to build the tools library
# --------------------------------------------------------------------
if (NOT BUILD_TESTING)
- ADD_SUBDIRECTORY (${HDF5_TOOLS_SOURCE_DIR}/lib)
+ add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/lib)
endif (NOT BUILD_TESTING)
#-- Add the h5diff and test executables
-ADD_SUBDIRECTORY (${HDF5_TOOLS_SOURCE_DIR}/h5diff)
+add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5diff)
#-- Add the h5ls executable
-ADD_SUBDIRECTORY (${HDF5_TOOLS_SOURCE_DIR}/h5ls)
+add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5ls)
#-- Misc Executables
-ADD_SUBDIRECTORY (${HDF5_TOOLS_SOURCE_DIR}/misc)
+add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/misc)
#-- Add the h5import and test executables
-ADD_SUBDIRECTORY (${HDF5_TOOLS_SOURCE_DIR}/h5import)
+add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5import)
#-- h5Repack executables
-ADD_SUBDIRECTORY (${HDF5_TOOLS_SOURCE_DIR}/h5repack)
+add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5repack)
#-- Add the h5dump and test executables
-ADD_SUBDIRECTORY (${HDF5_TOOLS_SOURCE_DIR}/h5jam)
+add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5jam)
#-- Add the h5copy and test executables
-ADD_SUBDIRECTORY (${HDF5_TOOLS_SOURCE_DIR}/h5copy)
+add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5copy)
#-- Add the h5stat and test executables
-ADD_SUBDIRECTORY (${HDF5_TOOLS_SOURCE_DIR}/h5stat)
+add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5stat)
#-- Add the h5dump and test executables
-ADD_SUBDIRECTORY (${HDF5_TOOLS_SOURCE_DIR}/h5dump)
+add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5dump)