summaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2016-10-27 15:03:22 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2016-10-27 15:03:22 (GMT)
commitb34423f620b470e1c5dc38cdd3abbd5fe8adc4ec (patch)
treea02a3c6e2eb895f6dc0a8e2f58e66f7c87a79406 /tools/CMakeLists.txt
parentb424328063646ff16877ecb7ee0132cab751da26 (diff)
downloadhdf5-b34423f620b470e1c5dc38cdd3abbd5fe8adc4ec.zip
hdf5-b34423f620b470e1c5dc38cdd3abbd5fe8adc4ec.tar.gz
hdf5-b34423f620b470e1c5dc38cdd3abbd5fe8adc4ec.tar.bz2
Split the code into src and test
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt45
1 files changed, 10 insertions, 35 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 0b6faa8..4b9b765 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -6,11 +6,6 @@ PROJECT (HDF5_TOOLS)
#-----------------------------------------------------------------------------
add_definitions (${HDF_EXTRA_C_FLAGS})
-#-----------------------------------------------------------------------------
-# Setup include Directories
-#-----------------------------------------------------------------------------
-INCLUDE_DIRECTORIES (${HDF5_TOOLS_SOURCE_DIR}/lib)
-
# --------------------------------------------------------------------
# If testing was NOT enabled, then we need to build the tools library
# --------------------------------------------------------------------
@@ -18,35 +13,15 @@ if (NOT BUILD_TESTING)
add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/lib)
endif (NOT BUILD_TESTING)
-#-- Add the h5diff and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5diff)
-
-#-- Add the h5ls executable
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5ls)
-
-#-- Misc Executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/misc)
-
-#-- Add the h5import and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5import)
-
-#-- h5Repack executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5repack)
-
-#-- Add the h5dump and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5jam)
-
-#-- Add the h5copy and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5copy)
-
-#-- Add the h5stat and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5stat)
-
-#-- Add the h5dump and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5dump)
+#-----------------------------------------------------------------------------
+# Setup include Directories
+#-----------------------------------------------------------------------------
+INCLUDE_DIRECTORIES (${HDF5_TOOLS_SOURCE_DIR}/lib)
-#-- Add the h5dump and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/h5format_convert)
+#-- Add the test sources
+add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/src)
-#-- Add the perform and test executables
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/perform)
+#-- Add the tests
+if (BUILD_TESTING)
+ add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/test)
+endif (BUILD_TESTING)