summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorDhvanil Popat <dpopat@hdfgroup.org>2019-06-25 01:40:07 (GMT)
committerDhvanil Popat <dpopat@hdfgroup.org>2019-06-25 01:40:07 (GMT)
commit5d954a0214fa92aec884cdbccab10632a925fc08 (patch)
treee0f7ec80bb373be7685f4b38c1e7ccdd5902c1b1 /tools/Makefile.am
parent39537399a10dc27ac22a804e55d77d7160d1bd76 (diff)
downloadhdf5-5d954a0214fa92aec884cdbccab10632a925fc08.zip
hdf5-5d954a0214fa92aec884cdbccab10632a925fc08.tar.gz
hdf5-5d954a0214fa92aec884cdbccab10632a925fc08.tar.bz2
Squash commit of options to build tools and tests
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index b0c33ed..4a59121 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -19,9 +19,15 @@
include $(top_srcdir)/config/commence.am
+if BUILD_TESTS_CONDITIONAL
+ TESTSERIAL_DIR =test
+else
+ TESTSERIAL_DIR=
+endif
+
CONFIG=ordered
# All subdirectories
-SUBDIRS=lib src test
+SUBDIRS=lib src $(TESTSERIAL_DIR)
include $(top_srcdir)/config/conclude.am