summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-11 17:40:52 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-11 17:40:52 (GMT)
commit3f0a35a4eab869793f5b3882da35a2fe0b683dbd (patch)
tree35c5a256e137aa8e16c120b4a59feab2cbeb2fe0 /tools/Makefile.am
parent54f376edbb1bce24bff19fb6b7c3d298470356be (diff)
downloadhdf5-3f0a35a4eab869793f5b3882da35a2fe0b683dbd.zip
hdf5-3f0a35a4eab869793f5b3882da35a2fe0b683dbd.tar.gz
hdf5-3f0a35a4eab869793f5b3882da35a2fe0b683dbd.tar.bz2
[svn-r9988] Purpose:
Bug fix Description: pmake (on modi4, for instance) complains about undefined variables if it is run without the -V flag, which turns those errors to warnings. Solution: Added test to configure.in to see if $MAKE will allow Makefiles with undefined variables. If not, sets -V flag in AM_MAKEFLAGS. Ensured that all custom make targets use AM_MAKEFLAGS. Also defined all variables that caused errors in top-level Makefile.am. This means that pmake can be used to build hdf5 *from the top level only*. To run make from a subdirectory, still need to use -V flag (or use make or gmake). Platforms tested: modi4, heping, copper, sleipnir
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am22
1 files changed, 0 insertions, 22 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index bbd0dbd..4a80c3a 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -23,26 +23,4 @@ include $(top_srcdir)/config/commence.am
# All subdirectories
SUBDIRS=lib h5dump h5diff h5ls misc gifconv h5import h5repack h5jam
-
-##lib:
-## (cd lib && $(MAKE) $@) || exit 1;
-
-##progs tests: $(LIBTOOLS) $(LIBHDF5)
-## @@SETX@; for d in X $(SUBDIRS); do \
-## if test $$d != X; then \
-## (cd $$d && $(MAKE) $@) || exit 1; \
-## fi; \
-## done
-
-##tests: $(LIBTOOLS) $(LIBHDF5)
-## @@SETX@; for d in X $(SUBDIRS); do \
-## if test $$d != X; then \
-## (cd $$d && $(MAKE) $@) || exit 1; \
-## fi; \
-## done
-
-# Makefile needs to recognize these targets
-#test _test: check
-#check-install:
-
include $(top_srcdir)/config/conclude.am