summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorDhvanil Popat <dpopat@hdfgroup.org>2019-07-05 18:31:46 (GMT)
committerDhvanil Popat <dpopat@hdfgroup.org>2019-07-05 18:31:46 (GMT)
commit89b2d1c8ce1f7b41343e45137ce8e037737ccd51 (patch)
tree5d5fd4c82eea981e87f9129a80485948d3a0e5ba /tools/Makefile.am
parentb43c2520bfc688e8f6245d35204e38cbcaaa0c58 (diff)
parentc56b9846c5277271dd07900b884da1abf1c9c21f (diff)
downloadhdf5-89b2d1c8ce1f7b41343e45137ce8e037737ccd51.zip
hdf5-89b2d1c8ce1f7b41343e45137ce8e037737ccd51.tar.gz
hdf5-89b2d1c8ce1f7b41343e45137ce8e037737ccd51.tar.bz2
Merge pull request #1786 in HDFFV/hdf5 from ~DPOPAT/hdf5:bugfix/HDFFV-10832_merge to hdf5_1_10
* commit 'c56b9846c5277271dd07900b884da1abf1c9c21f': Fixed name for 'Build HDF Tests' in CMake's libhdf5 settings Fixed options for CMake to correct names Added Tests/Tools to libhdf5.settings in cmake equivalent Minor fix in libhdf5.settings.in Squash commit of options to build tools and tests
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index b0c33ed..4a59121 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -19,9 +19,15 @@
include $(top_srcdir)/config/commence.am
+if BUILD_TESTS_CONDITIONAL
+ TESTSERIAL_DIR =test
+else
+ TESTSERIAL_DIR=
+endif
+
CONFIG=ordered
# All subdirectories
-SUBDIRS=lib src test
+SUBDIRS=lib src $(TESTSERIAL_DIR)
include $(top_srcdir)/config/conclude.am