summaryrefslogtreecommitdiffstats
path: root/tools/h5copy/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-03-24 19:38:44 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-03-24 19:38:44 (GMT)
commit356b1d0e15527dd16e827b464d9ba3b568c4ed2d (patch)
tree961803cb04ec0f4b88821a4e44b470283d96f6d4 /tools/h5copy/CMakeLists.txt
parent2a03914becde7312642c03861b2ca409c531b637 (diff)
downloadhdf5-356b1d0e15527dd16e827b464d9ba3b568c4ed2d.zip
hdf5-356b1d0e15527dd16e827b464d9ba3b568c4ed2d.tar.gz
hdf5-356b1d0e15527dd16e827b464d9ba3b568c4ed2d.tar.bz2
[svn-r20319] Correct depends of test for ADD_H5COPY_TEST
Bring r20318 from trunk
Diffstat (limited to 'tools/h5copy/CMakeLists.txt')
-rw-r--r--tools/h5copy/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/tools/h5copy/CMakeLists.txt b/tools/h5copy/CMakeLists.txt
index 9ce1558..46a928e 100644
--- a/tools/h5copy/CMakeLists.txt
+++ b/tools/h5copy/CMakeLists.txt
@@ -92,6 +92,10 @@ IF (BUILD_TESTING)
COMMAND $<TARGET_FILE:h5copy> -i ./testfiles/${infile} -o ./testfiles/${outfile} -${vparam} -s ${srcname} -d ${dstname}
)
ENDIF (NOT "${ARGN}" STREQUAL "")
+ IF (NOT "${last_test}" STREQUAL "")
+ SET_TESTS_PROPERTIES (H5COPY-${testname} PROPERTIES DEPENDS ${last_test})
+ ENDIF (NOT "${last_test}" STREQUAL "")
+ SET (last_test "H5COPY-${testname}")
# resultcode=2 will cause the test to skip the diff test
IF (NOT ${resultcode} STREQUAL "2")
ADD_TEST (
@@ -99,14 +103,11 @@ IF (BUILD_TESTING)
COMMAND $<TARGET_FILE:h5diff> -q ./testfiles/${infile} ./testfiles/${outfile} ${srcname} ${dstname}
)
SET_TESTS_PROPERTIES(H5COPY-DIFF_${testname} PROPERTIES DEPENDS H5COPY-${testname})
+ SET (last_test "H5COPY-DIFF_${testname}")
IF (${resultcode} STREQUAL "1")
SET_TESTS_PROPERTIES (H5COPY-DIFF_${testname} PROPERTIES WILL_FAIL "true")
ENDIF (${resultcode} STREQUAL "1")
ENDIF (NOT ${resultcode} STREQUAL "2")
- IF (NOT "${last_test}" STREQUAL "")
- SET_TESTS_PROPERTIES (H5COPY-${testname} PROPERTIES DEPENDS ${last_test})
- ENDIF (NOT "${last_test}" STREQUAL "")
- SET (last_test "H5COPY-DIFF_${testname}")
ENDMACRO (ADD_H5COPY_TEST)
#