summaryrefslogtreecommitdiffstats
path: root/tools/h5copy/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-12-30 14:03:15 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-12-30 14:03:15 (GMT)
commit8a7bf1ae4efd144ddf77f2a1c9701c36f913b5a4 (patch)
treeaf334956696330b4ce9811ca890d41bfd44770e2 /tools/h5copy/CMakeLists.txt
parenta863723db866ed63377aecd1e90cffa08f43c020 (diff)
downloadhdf5-8a7bf1ae4efd144ddf77f2a1c9701c36f913b5a4.zip
hdf5-8a7bf1ae4efd144ddf77f2a1c9701c36f913b5a4.tar.gz
hdf5-8a7bf1ae4efd144ddf77f2a1c9701c36f913b5a4.tar.bz2
[svn-r19898] Remove use of /MT compile flag for building static libs and programs. Added BUILT_AS_STATIC_LIBRARY define to set the windows import/export defines correctly for static libraries.
Diffstat (limited to 'tools/h5copy/CMakeLists.txt')
-rw-r--r--tools/h5copy/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/tools/h5copy/CMakeLists.txt b/tools/h5copy/CMakeLists.txt
index afb1ca7..affaf66 100644
--- a/tools/h5copy/CMakeLists.txt
+++ b/tools/h5copy/CMakeLists.txt
@@ -12,7 +12,6 @@ INCLUDE_DIRECTORIES (${HDF5_PROJECT_DIR}/test)
# --------------------------------------------------------------------
ADD_EXECUTABLE (h5copy ${HDF5_TOOLS_H5COPY_SOURCE_DIR}/h5copy.c)
H5_NAMING (h5copy)
-TARGET_WIN_PROPERTIES (h5copy)
TARGET_LINK_LIBRARIES (h5copy ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
SET (H5_DEP_EXECUTABLES h5copy)
@@ -27,7 +26,6 @@ IF (BUILD_TESTING)
IF (HDF5_BUILD_GENERATORS AND NOT BUILD_SHARED_LIBS)
ADD_EXECUTABLE (h5copygentest ${HDF5_TOOLS_H5COPY_SOURCE_DIR}/h5copygentest.c)
H5_NAMING (h5copygentest)
- TARGET_WIN_PROPERTIES (h5copygentest)
TARGET_LINK_LIBRARIES (h5copygentest ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
#ADD_TEST (NAME h5copygentest COMMAND $<TARGET_FILE:h5copygentest>)