summaryrefslogtreecommitdiffstats
path: root/tools/h5copy/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-08-31 20:20:12 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-08-31 20:20:12 (GMT)
commitc9cf76d5f9abff08e2488b79825551e99adecf42 (patch)
tree378c8c9f261dd362fe07aac3329eefab3122be72 /tools/h5copy/CMakeLists.txt
parent0792a4dd4c5dc399ed4a99c799e999d9e944b5ba (diff)
downloadhdf5-c9cf76d5f9abff08e2488b79825551e99adecf42.zip
hdf5-c9cf76d5f9abff08e2488b79825551e99adecf42.tar.gz
hdf5-c9cf76d5f9abff08e2488b79825551e99adecf42.tar.bz2
[svn-r19326] Added parallel build commands.
Corrected use/name of source folder aliases. Duplicated FindMPI.cmake so that non-c++ compiler is found first (recommemded commands did not work). Bring r19325 from trunk Tested: local linux with mpich
Diffstat (limited to 'tools/h5copy/CMakeLists.txt')
-rw-r--r--tools/h5copy/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/h5copy/CMakeLists.txt b/tools/h5copy/CMakeLists.txt
index 2cb3a43..b9dad2d 100644
--- a/tools/h5copy/CMakeLists.txt
+++ b/tools/h5copy/CMakeLists.txt
@@ -4,7 +4,7 @@ PROJECT (HDF5_TOOLS_H5COPY)
#-----------------------------------------------------------------------------
# Setup include Directories
#-----------------------------------------------------------------------------
-INCLUDE_DIRECTORIES (${HDF5_TOOLS_SOURCE_DIR}/lib)
+INCLUDE_DIRECTORIES (${HDF5_TOOLS_SRC_DIR}/lib)
INCLUDE_DIRECTORIES (${HDF5_PROJECT_DIR}/test)
# --------------------------------------------------------------------
@@ -33,7 +33,7 @@ SET (H5_DEP_EXECUTABLES h5copy)
##############################################################################
IF (BUILD_TESTING)
- IF (NOT BUILD_SHARED_LIBS)
+ IF (HDF5_BUILD_GENERATORS AND NOT BUILD_SHARED_LIBS)
ADD_EXECUTABLE (h5copygentest ${HDF5_TOOLS_H5COPY_SOURCE_DIR}/h5copygentest.c)
H5_NAMING (h5copygentest)
IF (WIN32)
@@ -47,7 +47,7 @@ IF (BUILD_TESTING)
TARGET_LINK_LIBRARIES (h5copygentest ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
#ADD_TEST (NAME h5copygentest COMMAND $<TARGET_FILE:h5copygentest>)
- ENDIF (NOT BUILD_SHARED_LIBS)
+ ENDIF (HDF5_BUILD_GENERATORS AND NOT BUILD_SHARED_LIBS)
# --------------------------------------------------------------------
# Copy all the HDF5 files from the test directory into the source directory